Rasbperry PI 3 OSMC A2DP install failed


I have a problem, and I am using the recommended way to report it as follows:

The issue you are currently experiencing with OSMC: tried to update my Raspberry PI 3 running OSMC with the A2DAP as described here:

I accessed the CLI locally as described here:

Navigate to the power icon in Kodi
Select Exit/Quit
Wait for the OSMC splash screen to appear
Press ESC on your keyboard
Login to your device using osmc for the username and password.

I typed the following:

echo “deb http://apt.osmc.tv jessie-devel main” | sudo tee /etc/apt/sources.list.d/a2dp.list
sudo apt-get update

I received error message after “sudo apt-get update”, saying that it was unable to do the update. Then I typed:

sudo apt-get upgrade

It did not ran (of course, but I forgot that it will not run.)

Then I tried to manually update OSMC via GUI, and I received the following error message:

OSMC Update Error
Error installing:
Please report this to the OSMC forum.

and a few seconds later:

OSMC updater
There are no updates available.

What you were doing when this issue occurred: nothing else

Whether you can replicate this issue on demand. If you can, then please provide some steps on how an OSMC developer can reproduce the same issue: Yes. Do the same.

The device you are currently running OSMC on: Raspberry PI 3

What peripherals are attached to the device? Wireless keyboard Logitech K400r, Maxtor external USB HDD

Has this issue been introduced by a new version of OSMC? When did the issue first appear and can you recall a time when it was not present? No, I think I have the 2017.10.0 version. I updated to this version previously, many weeks ago, using the GUI without any problems.

Logfile is uploaded to here: https://paste.osmc.tv/balufosuqu

Please help.

Thanks: Peter

Currently the a2dp testing would not work as the team is currently preparing the Debian change from Jessie to Stretch.

My recommendation:
sudo rm /etc/apt/sources.list.d/a2dp.list
sudo apt-get update
sudo apt-get dist-upgrade

and report the situation

Situation is normal, both update and upgrade successful, thank you for your quick help.
Regarding the Bluetooth streaming, what shall I do now? My idea is streaming music from my Android smart phone to OSMC/Kodi, and then listen to it on my TV and amplifier (wired connection).

The BT package needs some work to make it support stretch. As stretch is about to be released, I think you will have to wait a bit for that functionality.

Sam did say it was experimental, but it’s clear there’s demand for it.

OK, thanks, I will wait.