Rasp 3 fail on USB

I have a raspberry pi 3 with OSMC and a 3tb external disk drive installed and was running smoothly for a very long time until two days ago when I decide to play with some relays shields.
So I plug the relay on GPIO 4 (pin #7) and set the scripts to turn on and off the lights at a determined hour of the day.
Now, My external USB drive is not working anymore.
My first assumption was the power supply( although it states 2A max) was not good enough to take care of everything so I take the relay out. (it was a test only). Still nothing from the HD.
Reading the dmesg, there is a single line about usbstorage, but no more.
My question is: It is possible that I damage the rpi just because I use the wrong GPIO pin? The connections was correct. I did that several times before with an arduino, so I´m pretty confident about it…

Update 1: The external disk has its own power supply.


Sorry to hear you are having issues, have you tried the drive on another device?

Also if you could please provide debugging logs, more details on this can be found here.

These should show whats happening when OSMC tries to mount the drive, and we can advise further.

Thanks Tom.

On my Windows machine it´s working normally. I do not have another raspberry to try on.

I get the logs, read it but can´t find anything usefull.

I was hopping that someone suggests that GPIO 4 were a bad idea because it´s control something related with USB. I don´t know.
RPI doesn´t seen to send anything to HDD because even during reboot HDD stays completely disabled. I mean no sign of spinning or anything…

Thanks for your help so far…

First thing I initially notice unfortunately may have nothing to do with your issue, but detrimental overall -


If this is an Rpi3, you are severely underclocking it. If you’ve set clock speed by the presets in MyOSMC, revert it back to normal. This will give you default Rpi3 ARM clock speeds at 1.2Ghz. If you have these set manually in config.txt, just remove all your *_freq= lines.

1 Like

NO. I did trough MyOSMC. I will do that and send the logs again just in case…

Thanks for point me that out…

Yeah, we’re working on a new MyOSMC but, currently, presets are not compatible with Rpi3.

Could be that because all presets are bigger than the ones on my device.
However, I did select the normal mode. Seems to me the most reasonable.
Follow the new logs: http://paste.osmc.io/vehinawipa

You are in good shape now. Your rpi3 is now running faster than you had it configured before.

Problem solved!!
I alreade had rebooted my device, but only powering off then on again.
Now, I also remove it from RPI and it get recognized.
Don´t really now what happened, but is working now…
Thanks for everyone that helped me.