Rasp pi 2 version currently broken


I just signed up to this forum… I have been very satisfied with osmc / kodi, but after the latest update, the rasp pi version is broken.

  1. I had a working rasp pi 2 osmc/kodi working allright, untill today, when I stupidly enough, decided to do an online update

Now osmc freezes into the splash screen…! no ssh connection possible, nothing… complete freeze up!

  1. So, I took the latest rasp pi 2 image from the downloads page and wrote a fresh image on the sd card

Osmc starts okay, I configure it, everything works fine … but then it starts making updates, and again, I encounter the same problem as in (1)

Before committing updates, does anyone in this community, you know, like, test them?

How can I ban the updates after a fresh install for forever?

Could you try adding dtoverlay=mmc to your /boot/config.txt ?

There is a change in the sd card driver, if that fixes it for you, you likely have one of those incompatible cards.
If so … please mention your brand and model of the sd card right here.

like Theetjuh said, not updating would be a major mistake

Please search. The default SD card driver was changed by the Pi foundation. You likely have a card that doesn’t work well with it.

You can disable updates in My OSMC. This is outlined in the Wiki

I can understand your frustration but it’s not ‘broken’
In the last few days I have created new builds for a Pi2 and tested out a few different microSD cards and the installation and updates have worked fine. I was even impressed that it detected the Edimax wireless dongle without issues too.
FYI I used the ‘OSMC installer’ on Mint
You want frustration, try installing Windows 10 updates and drivers on a new laptop with a sh!tty internet connection for your neighbours :anguished:


It seems you noticed my frustration. :smirk:
Thanks for the quick replies and sorry about the frustrated tone. I think there is a duplicate issue on this on the forum:

I dont have any external card readers (?).

When it comes to windows 10, I try to avoid it at all cost! :sweat:

You must have a card reader in your laptop/desktop right?
It’s on the FAT32 part where you find the config.txt

Thanks Theetjuh!

That did the trick. I put those magic words (kernel driver for the sd card?) into the config.txt I found in the fat partition.

The sd card is
transcend premium 300x
16 gb

Thanks again!

A card that has been seen with this problem numerous times, for your info @DBMandrake

No problem, glad to help :smile: