Raspberry and TV HAT

Hello Every one,

I plugged my Tv HAT in yesterday and it seems that it doesn’t work. In tvheadend configuration there’s only IPTV tuner in the list.

What should I do to test my tvHat or to install it properly ?

Forward thanks
G

Hi

Which version of OSMC are you on? The HAT is supported in modern versions of OSMC

Sam

Does that mean it no longer works or is this the first time you’ve tried it?

Hello

This is a first try.
The green led is working

This is the very last version

I suggest uploading a log so we can see if it’s being detected on the system.

thank you so much for your help
can you please tell me how to do this with OSMC ?

https://osmc.tv/wiki/general/how-to-submit-a-useful-support-request/

1 Like

https://paste.osmc.tv/ipareqikak

Is that what you meant ?

I think most of us have a problem: we don’t have a TV HAT and don’t know what to look for in the log.

This is just a long shot but you can try adding the line

dtoverlay=rpi-tv

to /boot/config.txt and then reboot. (It’s a long shot because it should no longer be necessary – but worth a try.)

I do have the TV Hat and have given it some testing, where it’s working on OSMC here (tested quickly on Pi 3 A+).

The HAT design means that no modifications are needed to config.txt, as the device has a small EEPROM which tells the Pi which device tree overlays need to be loaded.

I don’t see the device detected on the system. I would suggest checking if it works under Raspbian – but I suspect there could be a hardware issue here.

As already mentioned, amending config.txt should no longer be necessary (because of the ID EEPROM). But it might be faulty, so the dtoverlay is worth a try.

1 Like

Thank You Sam for this precise answer.
I’ve tried with raspbian as well and despite of the green light is on and I tried to install tvheadend, I have the same issue. I’m very disappointed as my skill level with raspbian as reached its limit.

Once again, thank you for your help

I would recommend contacting the seller that you bought the device from, as I suspect that it is faulty.

1 Like

I did it yesterday evening
I’ll come back with news bad or good
Thanks again

Hello All,

here’s the update.

The board was not working. After the seller change it, it now works perfectly.

Thank you for your help. I have one more question but I wll search the forum first

2 Likes