Raspberry doesn't see NTFS HDD

Hi, I just bought a new raspberry 2 to replace my old raspsberry.
I installed OSMC alpha4 and I ran into a problem.

My 2TB 2,5 Zoll NTFS formated HDD won’t get recognized in fdisk.
I can see the HDD with lsusb. I tested with a USB stick and it gets recognized with no problem.
I tested with a HDD formated with exFAT and fdisk kann see it, too. NTFS-3g is installed.

Are you expecting it to automount in /media?

What does sudo /usr/bin/ntfs-fix /dev/sda output?

Can you try another drive freshly formatted as NTFS to rule out a filesystem issue?


ntfsfix shous my this:
Mounting volume... Error reading bootsector: Input/output error FAILED Attempting to correct errors... Error reading bootsector: Input/output error FAILED Failed to startup volume: Input/output error Error reading bootsector: Input/output error Volume is corrupt. You should run chkdsk.

The fresh formatted NTFS HDD is recognized, but only after a fresh formation. The former formatting
was NTFS to and it didn’t work.
I don’t think something is wrong with the 2TB HDD; since it worked without issues on my old raspberry and is recognized under Window and Ubuntu.
Also, chkdsk /f shows no error.


I have seen this before. I think you need to ‘Safely Remove Hardware’ to properly ensure OSMC mounts it every time.


Already tried that and windows and ubuntu, no luck.
Seems like I have to format my drive and copy the content back.

EDIT: Ok, the problem isn’t solved, the fresh formatted HDD won’t get recognized either, anymore.

EDIT2: So I did another reboot and now fdisk lists all my HDDs and everything is fine?
I just don’t know anymore, but I hope this stays fixed. Thanks for the help.

EDIT3: Turns out that the Rpi2 was falty. It died on me a few days ago.
Go a new one and have no problems at all with mounting HDDs.

I have recently purchased a RPi2 and have set it up with OSMC, reading from a networked HDD and from USB HDD but am now having difficulty setting it up with a NTFS HDD. I have tried sudo /usr/bin/ntfs-fix /dev/sda but it returns “command not found”?

Not sure where you received that command suggestion from, but you should not need to do anything for OSMC to run normally with this drive


It was from your post on the 5th Feb. I have tried the NTFS HDD via a usb hub and direct in the RPi but it doesn’t show up either way. The HDD works fine on my WinPC.

Some logs will help


What sort of logs?


Device: Rasp Pi2 Ram: 1024 Installation media: SDcard Connection: Wired Power Supply Type: Mains Peripherals: wifi dongle (Raspberry), eSYNiC wifi dongle for keyboard, powered USB hub.

I am trying to read from a powered USB NTFS formatted HDD, which contains some ripped blueray movies. I have tried setting up via the USB hub and directly plugged into the Pi2 but, where my FAT32 formatted unpowered USB HDD mounts, the NTFS HDD does not. I have no problems reading from a Fat32 HDD connected to my router or from USB sticks.

Dude… Reading my linked post describes exactly how to provide logs…

Sorry, missed the link. Will provide that info ASAP. Thanks.


I have also tried viewing the NTFS HDD whilst using Raspbian and can see it and the files without any problems.

Jul 28 17:40:24 osmc udisks-glue[372]: Failed to automount /dev/sda1: Error mounting: mount exited with exit code 14: The disk contains an unclean file system (0, 0).
Jul 28 17:40:24 osmc udisks-glue[372]: Metadata kept in Windows cache, refused to mount.
Jul 28 17:40:24 osmc udisks-glue[372]: Failed to mount '/dev/sda1': Operation not permitted
Jul 28 17:40:24 osmc udisks-glue[372]: The NTFS partition is in an unsafe state. Please resume and shutdown
Jul 28 17:40:24 osmc udisks-glue[372]: Windows fully (no hibernation or fast restarting), or mount the volume
Jul 28 17:40:24 osmc udisks-glue[372]: read-only with the 'ro' mount option.
Jul 28 17:40:24 osmc udisks-glue[372]: Device file /dev/sdb1 mounted at /media/EFI
Jul 28 17:40:24 osmc connmand[307]: Setting domainname to home
Jul 28 17:40:24 osmc udisks-glue[372]: Device file /dev/sdb2 mounted at /media/WD Passport
Jul 28 17:40:24 osmc udisks-glue[372]: Device file /dev/sdc1 mounted at /media/UNTITLED

Have you first tried disconnecting all other HDD except the problematic one to see if the issue persists? If so, can you try the ntfsfix command as described in the accepted answer in the link below? (No need to install ntfsprogs, the command already exists in OSMC. )

1 Like

Yes, I had tried the HDD on its own and no dice, tried the ntfsfix line and now it’s working and I can see the drive and the files. Thank you.


The issue here is that you need to use ‘Safely remove hardware’ in Windows, or the dirty bit gets set and then Linux will only mount it in read-only.

We can probably change this