Raspberry & Mycloud NAS failures

Evening everyone.

I’m stuck and really need some help. I’ve got a raspberry pi 3 working as my osmc player. It’s wired to my isp router which in turn is wired to my storage western digital NAS. I’be got a section on there for my movies and inside that are several folders for genre. One folder however which is newly made contains all the recent additions.

Playback of these items seems extremely flakey though. 7-8/10 times the playback will show a progress circle but nothing ever comes of it. I don’t think the machine is locked up as I can ssh and restart the box. I can also restart the Kodi program too. If left the playback never starts, it’s been left overnight and still not start.

I’m at a loss as to what’s causing the issue. I’be replaced all network cables. Changed over my raspberry box. Re-imaged the micro ssd. Even tried OpenELEC and LibreELEC neither of which made any difference.
The only time this all worked was prior to installing Kodi 17. The only folder that fails usually is the new files folder. Action, Sci-fi etc all movies play first time.

The sources are added as nfs shares and changing the content type from movies to file type view makes no difference either. There are no addons on the device other than standard stuff like subtitles and IMDb scrapers.

Can anyone advise me on something to do or check to improve performance this has been going on for months and I’ve lost the will to keep trying to work it out.

Thanks in advance.

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

So, in summary:

  • activate the logging
  • reboot the OSMC device
  • reproduce the issue
  • upload the log set either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A
  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

Check network with iperf3

Use kernel mounts instead of Kodi mounts: