Raspberry Osmc like Nas or similar.Help

Good morning, and merry Christmas, estopy riding a raspberry reed with Osmc, and I would like to have one as a server, where I am going to connect the hard drives to usb and the rest 2 or 3, as clients that reproduce from the server, is possible?
I tried, I shared the server database, but at the time of playback from a clutch I can not, it tells me that the file is not already available.
I have installed on the samba server.
Any suggestions?

Do you mean that you use a shared MySQL database?
If that is the case than you need to either ensure the path to the network files is the same on all machines or you need to use path substitution

On one of the machines your trying and failing to connect I would turn on debug logging, reboot twice, try to play one of the files, then upload logs with the My OSMC add-on making sure the all logs option is enabled. This should allow us to see enough to point you to a solution.

Hello, here I leave the logs, one is the local of the temp folder, and the other is the global one from OSMC.
I detail what I want to do and how it is configured.
In a raspberry that I call server, does it have a USB connected whit a movie, this raspberry has the samba server installed only, supposedly the usb does auto-share, no? it has shared the database, that works correctly.
The other raspberry has nothing special installed or nothing configured except the advanceseting.xml where the ip address of the raspberry server is indicated.
The error that comes out is that when going to play the video of the server, the client says, this file does not exist, it tries to open it in the address /media/usb and I don’t know how to change that from the client.


Thank you!!!

global log https://paste.osmc.tv/kotahewove
local log https://paste.osmc.tv/utivodexic.xml

That’s where you need to use path substitution or you need to mount the Samba share under the same folder.


Try this. You might need to also delete or edit passwords.xml as I think that may have an incorrect entry in it.


Ohuuuuuuu Thank you!!! It already works as I want !!!
problem solved!!!

1 Like