Raspberry Pi 3 B+ Leia 18.6 - Video very pixilated with Onkyo AV-Receiver

Hi All,

to get audio passthrough running I connected the Pi3 directly to my Onky TX-NR676 with HDMI.
Audio passthrough is now working ;D
BUT now the video is completely out of focus ;-(
I checked the information
kodi : 1920x1080@60Hz - fullscreen
onkyo: 1920x1080p 60Hz RGB 24 bit and very very pixilated

How can I get the RGB to full?
I already tried the following without success:

hdmi_pixel_encoding=2

The only difference I could figure out is: at 43 / at 48 (What does this mean?)

connected to onkyo

2020-04-21 15:13:25.227 T:1915356720 NOTICE: Found (1920x1080@60.000000) at 43, setting to RES_DESKTOP at 16
2020-04-21 15:13:25.228 T:1915356720 NOTICE: EGL_VERSION = 1.4
2020-04-21 15:13:25.228 T:1915356720 NOTICE: EGL_VENDOR = Broadcom

root@osmc-Wohnzimmer-Pi3 ~ # tvservice -s
state 0x12000a [HDMI CEA (16) RGB lim 16:9], 1920x1080 @ 60.00Hz, progressive

connected to TV

2020-04-21 15:25:57.082 T:1916102192 NOTICE: Found resolution 1920 x 1080 with 1920 x 1080 @ 29.970032 Hz
2020-04-21 15:25:57.082 T:1916102192 NOTICE: Found (1920x1080@60.000000) at 48, setting to RES_DESKTOP at 16

root@osmc-Wohnzimmer-Pi3 ~ # tvservice -s
state 0x12000a [HDMI CEA (16) RGB lim 16:9], 1920x1080 @ 60.00Hz, progressive

Any ideas what I can do or what for information is needed for further help?

Thanks and best regards
Fabian

To start I would turn on debug logging, reboot twice, play a file that is affected for a few seconds, stop, then upload full logs with the My OSMC add-on.

Stupid question. I enabled logging, clicked uploaded selected logs now.
But where do I see the URL link?

After you click on the upload selected logs now there should be a short delay and then a notification should popup with something like https://paste.osmc.tv/lksljlk (the last bit being a randomized string), that is the url, and you would need to make a note of that and post that output in this thread so we know where your logs are located.

Thanks, but I don’t get any popup… strange…
But, I could create the logs from the cli with:

grab-logs -A

https://paste.osmc.tv/paqevogagi

The problem with the very very pixilated screen is not related to playing a video, also the GUI (home) is affected. (i.e. the cover picture from movies or TV shows)
And only while connected directly to the Onkyo with HDMI.
Directly connected to the TV everything is fine.
But, I would prefer connecting directly to Onky, so that I can use audio passthrough.

Hopefully you can find anything in the debug logs.

Thanks

Your RPi appears to be sending out 1080p60 just like you set it to. I would look for maybe something to tweak in the Onkyo (video processing settings, change input). I tried bring up a manual but what Onkyo has on their site was a joke and didn’t give me a clue what video processing it might be doing, or if it was doing any at all. About the only thing I could think you could do on the RPi side is maybe try adding a “config_hdmi_boost=7” in your config.txt

On a completely unrelated note, is that path substitution for your sources actually working? I thought that was supposed to be broken using it that way. Is it working because you added your credentials to the substitution?

Also with “config_hdmi_boost=7” the view is looking very bad pixilated.
Yesterday i also checked the Onkyo website for a manual, but couldn’t find anything helpfully for configuring the video output/input.

I tried to take a photo from that what I mean, but you can’t see it on a taken photo.
With a kodi screenshot everything is looking good ;D
So it must be a problem with the video output from the raspberry or video input onkyo.
Hopefully any other ideas?

You are right, path substitution for sources are not working anymore. It’s just a relict from an older kodi version :wink:

Is there a 3D mode in your TV that is getting turning on when your running through your AVR?

Thanks for confirming

First idea I have to try another hdmi cable but could you present a picture/photo here what you mean with pixilated in detail?

Must be quite minimal not big pixelation

No, there is no 3D mode active

I tried 2 other cables :slightly_smiling_face:
Hopefully you can see what I mean:

And how it looks like if you direct connect the Pi to the TV?

Do you have another device you can plug into that AVR to see if the video gets screwed up the same as it does with the RPi? It’s kind of hard to tell with that image, but is your issue with posterization?

I think he means the Moiré pattern. We should first try to find out whether the AVR introduces the issue or it is already located to the TV.

Seems only to happen when connected via the AVR.
But as you asked it would be best to see a picture when directly connected to the TV to understand what the problem is. Because Moire Effect might have just come by the phone taking the picture.

You are definitely right, my problem looks like Moiré pattern!!! That‘s what I wanted to describe :slightly_smiling_face:

I connected another Pi directly to the AVR and it‘s the same. Later I will connect my MacBook and see what happen.

With a taken photo you cannot see the difference AVR/TV connected.

Was the Pi also running OSMC?

OK, with my MacBook I have the same effect.
Sorry for not testing this first :innocent:

It must be a problem with the Onkyo! :grimacing:

1 Like