Raspberry PI 3 Model B+ Lan Adaptar

Dear all,

I bought a new Raspberry Pi 3 Model B+ today and a new micro SD. Installed the OSMC March realease.

Everything is ok but when I try to enable the Lan adapter it loads but after a while it does not connect.

Tried with a short cable and a long cable dont work. Tried those cables with my old Raspberry Pi 3 and works

Tried the same card with a Raspberry 3 normal and works.

Wifi works on the new raspberry pi 3 +.

Is there a way to test if the lan port is working ? Or I need to go and ask to replace my raspberry.

Thanks all.

Before doing that, just try the latest Raspbian Image as a reference first to ensure it is not a software issue

Also - are you connecting to a gigabit ethernet switch?
Usually it works without a problem but there have been some reports on Raspberry Pi forum about a lot of retransmits when connecting to one. This would usually result in slower throughput but perhaps in extreme situations it could be reported as a failure.

I would like to mention that I’m having the exact same problem as the OP.
I have tried two different install of OSMC and neither have working ethernet.
I did do a quick Raspbian image install on another card (really annoying because I didn’t have a spare but whatever) and it works fine with ethernet that just works.

So it is not a hardware problem.

I have ran out of time right now so I can’t get any logs right now but I will work on them tomorrow if I have time. I just wanted the OP to know it is not likely a hardware problem for him either.


Hopefully the issue is now addressed with the following commit:

I’d appreciate it if you could test this and provide feedback before we potentially release this as an update to other users. To test this update:

  1. Login via the command line
  2. Edit the file /etc/apt/sources.list
  3. Add the following line: deb http://apt.osmc.tv stretch-devel main
  4. Run the following commands to update: sudo apt-get update && sudo apt-get dist-upgrade && reboot
  5. Your system should have have received the update.

Please see if the issue is resolved.

I also recommend you edit /etc/apt/sources.list again and remove the line that you added after updating. This will return you to the normal update channel.

My system can’t find that update to test it. I even manually browsed the repo and don’t see the updated package.

I’m not sure what you mean by this.
What’s the output of dist-upgrade?

Did you change your sources.list? Did you run update/dist-upgrade? I am getting the -30 Kerenl when doing that.

osmc@osmc-test:~$ nano /etc/apt/sources.list
osmc@osmc-test:~$ sudo apt-get update
Ign:1 http://ftp.debian.org/debian stretch InRelease                
Get:3 http://security.debian.org stretch/updates InRelease [63.0 kB]
Get:4 http://ftp.debian.org/debian stretch-updates InRelease [91.0 kB]          
Hit:6 http://ftp.debian.org/debian stretch Release                                          
Hit:2 http://ftp.fau.de/osmc/osmc/apt stretch InRelease                  
Get:5 http://ftp.fau.de/osmc/osmc/apt stretch-devel InRelease [4,700 B]
Get:7 http://security.debian.org stretch/updates/main armhf Packages [347 kB]
Get:9 http://ftp.fau.de/osmc/osmc/apt stretch-devel/main armhf Packages.diff/Index [2,023 B]
Get:10 http://ftp.fau.de/osmc/osmc/apt stretch-devel/main armhf Packages [29.6 kB]                 
Fetched 537 kB in 6s (82.8 kB/s)                                                                   
Reading package lists... Done
osmc@osmc-test:~$ sudo apt-get dist-upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
The following packages were automatically installed and are no longer required:
  libiso9660-8 libnspr4 libnss3
Use 'sudo apt autoremove' to remove them.
The following NEW packages will be installed:
The following packages will be upgraded:
  libicu57 rbp2-kernel-osmc
2 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 20.2 MB/27.7 MB of archives.
After this operation, 70.1 MB of additional disk space will be used.

I thought I’d test this update to see if it helped any with my periodic hangs when fast forwarding video that’s stored on a remote device. After adding the dev channel and running the updates, I now can’t use the Ethernet port at all in OSMC. It shows as a device in ifconfig, but MyOSMC says there is “No wired connection” in the status. The switch on the port is showing a 1gig connection, and the yellow light on the 3b+ ethernet port is blinking yellow. I’ve resorted to the wireless connection for now. ifconfig seems to think there’s a wired connection:

eth0: flags=-28669<UP,BROADCAST,MULTICAST,DYNAMIC> mtu 1500
ether b8:27:eb:60:4d:29 txqueuelen 1000 (Ethernet)
RX packets 0 bytes 0 (0.0 B)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 0 bytes 0 (0.0 B)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

lo: flags=73<UP,LOOPBACK,RUNNING> mtu 65536
inet netmask
inet6 ::1 prefixlen 128 scopeid 0x10
loop txqueuelen 1000 (Local Loopback)
RX packets 112 bytes 8768 (8.5 KiB)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 112 bytes 8768 (8.5 KiB)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

wlan0: flags=-28605<UP,BROADCAST,RUNNING,MULTICAST,DYNAMIC> mtu 1500
inet netmask broadcast
ether b8:27:eb:35:18:7c txqueuelen 1000 (Ethernet)
RX packets 1095 bytes 178127 (173.9 KiB)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 854 bytes 133636 (130.5 KiB)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

Any suggestions on how to collect logs on this? If I disable wireless I have no internet, and I feel like it I don’t try with only wired the logs won’t say anything useful.

It turns out my apt update failed so the dist-upgrade failed to see the new file. I have it installed now but it has no change.

You can use -C switch on grab-logs to write logs to /boot. Than you can reconnect wireless and upload logs with paste-log /boot/uploadlog.txt

Thanks. Here are the logs that should hopefully contained the failed boot attempt with the wired ethernet port and the updated stuff from the devel channel.


There are a few posts above mentioned that the latest OSMC image causes problems with the wired ethernet (eth0) on the new Raspberry 3B+. I can confirm the issue: ip link always reports “NO CARRIER” but in fact the line is connected. I tried different settings (disabling connman, manually bringing up eth0 etc.) but without any change. After forcing the system over to the latest Raspbian kernel (via “sudo -E RPI_UPDATE_UNSUPPORTED=0 rpi-update”), the problem was solved and eth0 worked flawlessly. This can be reproduced: after going back to OSMC kernel via “sudo apt-get --reinstall install rbp2-image-4.14.30-3-osmc”), the NO CARRIER message returned and eth0 was unusable.

I am not sure what kind of logs I can submit to support this report. Basically, all that is said with respect to eth0 in journalctl -xe is “no carrier”.

We’re aware of some problems with the new adapter and will pull in some fixes soon.

Moved you post here as I assume this thread is more related than the Kodi 18 testing thread.

Thank you.

The latest osmc kernel now works with eth0 on a Raspberry 3B+. Great.