Raspberry Pi 3, new install, no HDMI audio

Hi there,

I’m a bit of a newb so forgive me if I’ve missed something obvious.

I’m using a new Rpi 3, with a fresh install of the latest version of OSMC on a brand new Sandisk Extreme 16gb micro SD card. Everything went well, boots up and works great and plays video files great from the portable HDD via usb.

Only problem though is I don’t get any audio over HDMI.

If I plug the same HDD into my laptop and plug my laptop into the same HDMI lead going to the same TV then play the same video file everything works great.

I’ve changed the audio output to “both HDMI and Analogue” in the settings and added the “HDMI_DRIVE=2” line to the config file with no change. I’m sure I’m missing some simple step so any help is appreciated.

Thanks

Do you have passthrough activated?
Can we get logs and a mediainfo on the file please?

See here:
http://osmc.tv/wiki/general/how-to-submit-a-useful-support-request/

I tried with and without passthrough activated. I’ll upload logs when I am home from work. The media I’m trying to play doesn’t seem relative to the problem. Tried a mix of AVI, MP4, MKV and some random MP3 music files. All files work as they should when the Pi is swapped for a laptop using VLC and a different laptop using iTunes for the iTunes compatible files and the on board USB player for the TV as well as an older Pi2 running OSMC.

Am I correct in assuming the normal scenario would be to use the OSMC installer to populate a suitable MicroSD card, then the MicroSD card is installed into the Pi, then once the installation is completed and set up it should just work with audio and video over HDMI if that’s all that is plugged in?

Thanks

Yes. It should work out of the box.
You can have a look at the audio output settings. Make sure hdmi is activated. Also you can try to use a different hdmi cable.

Thanks for confirming. I tried setting the audio output to only HDMI then when that didn’t work I set it to Analogue and HDMI with no change. I’ll have a double check the Expert settings tonight when I upload the logs.
The HDMI cable works with 2 laptops and another pi running OSMC so I will freak right out if it decides not to work with this pi for some reason.

So full debug logs would be good.
Does putting one or both of the lines below in /boot/config.txt make a difference?

hdmi_force_hotplug=1
hdmi_drive=2

I tried adding the “hdmi_drive=2” with no change. I will try the “hdmi_force_hotplug=1” tonight too. Cheers for the tip

Another thing to check is if you have muted the audio or turned down the volume by accident.

Will do. Thanks a bunch for your help. I really appreciate it. I will report back with the logs or any solution that comes up tonight

Good morning! So I got home last night and tried entering “hdmi_force_hotplug=1” in the config. No change. I then reformatted the MicroSD card and re-installed osmc and hey presto! Everything works perfectly. I’m thinking perhaps the problem was occurred when I did the initial install and setup using my computer monitor at work (no speakers) which may have caused the OS to turn off sound output from the HDMI. Now that I did the new install and setup on my TV (with speakers) perhaps it sees the speakers and knows to use them.
Pure speculation but either way it works now. Thank you so much for you time and help.