Raspberry Pi 3 Octagon sf 8008


Osmc installed on Raspberry Pi 3 does not read the subtitles from Octagon satellite recordings. I need this wonderfull Media Center does it without delay between sound track and subtitles. Can it be realized ?

Try enabling settings>player>language>enable parsing of closed captions

It works with one recording from a channel and does not work with two recordings from an other channel.

Are you sure that these recordings all have subtitles embedded? Have you actually checked with something like mediaInfo?

There are 7 files for each recording. One must be subtitles. The subtitles are not embedded to the .ts file I think. If I do a search for subtitles there is none of the 7 files like I can get with a .srt file.

Why do you think the subtitle “must” be there? Is there some other player that is showing subs where Kodi is not? Did you try the program I linked to above to see what was actually in the files?

But I am sure there are subtitles. It works with vlc.

Can you upload a sample clip of something that the subs are working in VLC but not Kodi?

There is just my word. You can believe me.

Osmc reads files with the most significative fluidity and quality than vlc does not get. And my raspberry has a remote control than my pc do not have. It would be great if I could see the subtitles from Enigma2 files. Perhaps I do not know how to use Osmc or perhaps this functionnality is not implemented in the source code. Perhaps Sam Nazarko can help me?


Please either provide mediainfo or a sample clip of an affected recording?

Regards Tom.

Here is MediaInfo capture.

Is settings>player>videos>activate teletext enabled?