Raspberry Pi 3 OSMC June 23 Bluetooth not pairing

I am trying to get Bluetooth paired but get the error below in logs. My full log file is here.

Is this the same as the issues posted all the way back to 2018? I was hoping it might be fixed in a more recent update.

Blockquote 2023-07-05 07:45:22.898 T:1005 debug : script.module.osmcsetting.networking[networking_gui] : Unhandled Exception thrown in Networking GUI
Traceback (most recent call last):
File “/usr/share/kodi/addons/script.module.osmcsetting.networking/resources/lib/osmcnetworking/networking_gui.py”, line 421, in onClick
File “/usr/share/kodi/addons/script.module.osmcsetting.networking/resources/lib/osmcnetworking/networking_gui.py”, line 1553, in handle_bluetooth_selection
result = self.osmc_bluetooth.pair_device(address, self.lib_path)
File “/usr/share/kodi/addons/script.module.osmcsetting.networking/resources/lib/osmcnetworking/osmc_bluetooth.py”, line 225, in pair_device
paired = pair_with_agent(_osmc_bt = self, device_uuid = device_address)
File “/usr/share/kodi/addons/script.module.osmcsetting.networking/resources/lib/osmcnetworking/osmc_bluetooth_agent.py”, line 255, in pair_with_agent
agent = AgentInterface(rvl_conn, capability)
File “/usr/share/kodi/addons/script.module.osmcsetting.networking/resources/lib/osmcnetworking/osmc_bluetooth_agent.py”, line 110, in init
self.handle_agent_manager(True, capability)
File “/usr/share/kodi/addons/script.module.osmcsetting.networking/resources/lib/osmcnetworking/osmc_bluetooth_agent.py”, line 132, in handle_agent_manager
reply = self.conn.connection.send_with_reply_and_block(message, error = error)
File “/usr/lib/python3/dist-packages/dbussy.py”, line 2256, in send_with_reply_and_block
File “/usr/lib/python3/dist-packages/dbussy.py”, line 5035, in raise_if_set
raise DBusError(self.name, self.message)
dbussy.DBusError: org.bluez.Error.AlreadyExists – Already Exists

I don’t think so. There seems to be a package missing. Try updating from MyOSMC or the command line sudo apt-get update && sudo apt-get dist-upgrade

Thanks for the suggestion. I ran those commands and some packages were updated. After rebooting I tried to pair again and same error occurred. My log file is here and the error has a timestamp of 2023-07-05 20:17:12.839 T:650 in case anyone has any other ideas.

what does bluetoothctl devices say?

I ran through the bluetoothctl devices command and it didn’t let me get any further it would detect the device when scanning but wouldn’t connect. Then I had an idea to try connecting to another Bluetooth device I had which worked absolutely fine.

The second device which worked is a fairly new UE Boom speaker, the device which won’t connect is an older Logitech Bluetooth Adaptor that outputs to RCA for use with a home stereo.

My Raspberry Pi has a LMP version of 4.1 which from what I have read should work with older Bluetooth versions but I’m guessing it doesn’t work with whatever version the Logitech adaptor has. I can connect to the Logitech Adaptor fine from multiple Android + Windows devices so the device itself is fine.

Any tips on how to navigate this area would be great as I am kind of stuck now knowing a likely cause but not how to figure out if a solution is possible :slight_smile:

BT is a minefield. You mention June 23. Did it work before then as I don’t think anything has changed in bluetooth or bluez-alsa.

Do you have a BT USB dongle to try? You would need to disable the internal BT on the Pi with a config line.

My mention of June 23 was just that is the OSMC update I have applied as I hadn’t touched my RPi since 2020 so put the latest version on.

I have tried experimenting with an old Bluetooth dongle I had around but can’t get the dongle to be recognised. I think I am going to call it a day at this stage as I now know the issue is with my Logitech device not OSMC or the RPi so will probably just buy a newer audio device and hope it works OK as the one I have is pretty ancient.

Thanks for all your help to get me this far though.

You don’t say how far you got - did it pair? I’ve just come across an issue with another BT device - it pairs but won’t connect within the approx 5 seconds following bluetoothctl connect and I get Failed to connect: org.bluez.Error.Failed br-connection-page-timeout. After 3 or 4 attempts it works.

For the life of me I can’t find out how to increase the timeout, other than recompiling bluez which is bonkers.

I got the Logitech device to display after scanning but it never paired. It always failed with org.bluez.error.connectionattemptfailed