Raspberry Pi 3 suddenly slow stuttering video playback

My Raspberry Pi suddenly started becoming slow and unresponsive within the last couple of days and video playback (both from my hard drive and streaming through apps) stutters. I tried playing the same video that I had watched the other day that played fine and it now stutters. Any help would be great.

Here are my logs


mv .kodi kodi.bak and re-test without all your installed cruft. If the issue then persists, provide grab-logs -A

sorry I dont know what you mean. Can you dumb that down a bit? Im kind of a noob

nevermind I got it. it seemed to help a bit but it seems to be getting hot (the overheating icon comes on). still lags a little but that may be from the overheating…how do I reverse the mv. kodi kodi.bak? is it related to an addon then or…?

We need to see the issue demonstrated without all of your “streaming addons” which we have no intention of addressing or providing any support for. Using SSH to connect to your device and issuing the command above will revert Kodi to the same state as a clean install (while saving your previous configuration/addons) so that you can simply add your HDD sources and create the problem while you have debug logging enabled.

To revert, mv kodi.bak .kodi


here is my log after doing that

Also, from your log,
you are underclocking your pi. Go back into MyOSMC and set overclocking to “Normal”. But if you are already overheating, this is not gonna help. You need to at least ventilate the device better than you are currently.

underclocking or over? I originally set it to turbo

The MyOSMC overclock presets have never been configured for an Rpi3. They will be updated in the future. 1000 was the turbo setting for a Pi1/2. Set it back to normal and you will see your Pi3 using 1200 as default. Problem is, it will likely run hotter.

i manually set it to 1200, 500 and 500…I will try moving the pi so it will get more ventilation

Don’t manually set it… Just set normal…

normal reverts it to 900 for some reason

You will not see the true clockings in MyOSMC when using an Rpi3! Set normal, reboot, check your Kodi.log or the Kodi System Info page and you will see.

ok Ill try that. so do you think it was due to an addon I installed?

I don’t have a clue. After renaming the folder and using a clean install, did your files then play correctly?

other than a little lag (I think because of the overheating) they seemed to play better. I did install a new addon recently so maybe Ill try uninstalling that.