Raspberry Pi 3 - ***Wifi Mega Thread***

just now updated OSMC in RP2, transferred card to RP3 - still no wifi or live tv. Suspect TV problem will disappear once wifi is working. What else do I need to do?

My bad. WIFI is available in MyOSMC. SET up ok. Changed ip address in PVR client. TV now working too. Occasional sad face when changing channels - will test tomorrow. Well done Sam. Good work.

Continuing to get sad face occasionally when changing channels and once when tvheadend loading epg. I uploaded log from myomsc. Would like to know how log can be tied to this description?
One other thing, when checking addons, i noticed that every single language addon was enabled, with no means of disabling them. Don’t know if its always been like that but don’t recall it.

You need to post the URL provided to you here.

Wonder if someone can help please. Quite New too this. Bought a pi 3 installed osmc via noobs and osmc disc image but cannot see the wifi adaptor in osmc network settings either way. Only wired. Set up a pi 2 before with a wifi dongle and osmc finds it ok.
Thanks in advance.

I had exactly the same on an upgrade from a a pi2.
There seems to be an issue with recognising the wifi exists on a pi3. dmesg didn’t show any reference to wifi, as if the hardware wan’t there.
My solution was a fresh install from a new downloaded osmc image.

I tried the full raspbian image from raspberry.pi.org website (not the lite one) and the wifi worked from that, so I knew it wasn’t a hardware issue. My guess is something in the wifi initialisation/detection code isn’t quite right yet, or maybe doesn’t reset the hardware properly? but once it was working from raspbian it worked from osmc and has been fine ever since.

Hope this helps get you going too.

1 Like

I had a similar issue this evening!

I found that if I updated OSMC (using a wired connection or the wifi adapter from my pi 2) I managed to get the additional wireless connection show up.

1 Like

Thanks for the reply. Will give it a go.

I’m getting insane slow Downloadspeeds on my Pi 3 with the build in WiFi-Dongle. Using iwconf wlan0 power off lowered latencys, but iperf shows that im getting ~1,5Mbits down but over 40Mbits upload. Already tried to use different channels
IEEE 802.11bgn ESSID:"@@@"
Mode:Managed Frequency:2.432 GHz Access Point: …
Bit Rate=72.2 Mb/s Tx-Power=31 dBm
Retry short limit:7 RTS thr:off Fragment thr:off
Power Management:off
Link Quality=41/70 Signal level=-69 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

Anyone getting the same bad perfmormance?


I have a Raspberry Pi 3 with a fresh osmc install (last version, and applied all update).

My sd card do not work with sdhost drivers so I have to add “dtoverlay=mmc” to config.txt.

But when I add “dtoverlay=mmc” to config.txt the Wireless adapter disappear from “My OSMC” network, I only have “Wired” available.

Here is some log : http://paste.osmc.io/agikequruc

Anyone have an idea to bring back the Wireless Adapter?



The on-board Wireless integration requires the SDHost driver.

If you can, please write down the make and model of your card.

Thanks for your quick reply :slight_smile:

Kingston MicroSDHC
Class 10
SDC 10/32GB

I read the other thread about SD card problem… maybe I should buy a sandisk sd card to solve my problem.

Thanks again for your support.


A lot of users prefer Samsung EVO or SanDisk cards here. I like SanDisk a lot, but things may change in a couple of weeks…

Kingston can be problematic, and at best, provides lackluster random write speeds that don’t really bring out the best in OSMC.


Thanks for your time, I appreciate.

I’ll try a different sd card.

Sorry for interrupting, but why???

Why is the SDHost driver needed for WiFi? Because WiFi is hooked up via SDIO.

Why do we want the make and model of the card? To identify potentially problematic cards.

Thanks for the answer, thats cleared it

Not sure which one I answered though…


Using latest OSMC on rpi3. But dont see onboard wifi in osmc settings.

Heres debug log

Heres dmesg log

I transferred updated sdcard from pi2 to pi3.

Thanks for any info

Edit Solved: by removing the line dtoverlay=sdhost from config.txt. Seems sdhost is already enabled.

Well the connection to the raspi 3 over wifi is now really rediculous.
I installed the latest update.

PING ( 56 data bytes
64 bytes from seq=3 ttl=64 time=2113.249 ms
64 bytes from seq=4 ttl=64 time=1113.592 ms
64 bytes from seq=5 ttl=64 time=113.460 ms
64 bytes from seq=6 ttl=64 time=154.824 ms
64 bytes from seq=7 ttl=64 time=1299.710 ms
64 bytes from seq=8 ttl=64 time=300.297 ms
64 bytes from seq=9 ttl=64 time=1124.829 ms
64 bytes from seq=10 ttl=64 time=125.636 ms
— ping statistics —
12 packets transmitted, 8 packets received, 33% packet loss
round-trip min/avg/max = 113.460/793.199/2113.249 ms