Raspberry Pi 3 - ***Wifi Mega Thread***

Hi there, I am trying to enable Wifi on the new Raspberry Pi 3. It seems the drivers are missing and I can’t seem to install them. Any ideas?

An update will come shortly, and this will enable functionality.

Cheers

Sam

Hi sorry. Do you have an ETA :slightly_smiling:?

When it’s ready. Asking every 12 hours for an ETA won’t expedidite the process

hi
anyone know howto enable the built in wifi??

Again… just a simple search…

1 Like

That is kind of a bitter answer. I tried to search, I could not find any solution for a few hours yesterday. If you have a source to fix this, please link.

1 Like

Also, this question does not have anything to do with this topic. Not sure why it got merged. Booting is no problem, the built in wifi chip is the problem…

My OSMC -> Updater -> Check for Updates

And WiFi should start working.

1 Like

no updates available…

Coming back to topic, just updated via My OSMC but no wifi in settings. Tried to disconnect LAN and even restart it but still no luck.

I’m not pushing for it at all as it’s not my priority but wanted to flag it up. The only choice in Network setting are still Wired and MySQL.

2 Likes

Need to see logs.

Otherwise the new images coming out aren’t going to magically enable WiFi.

Sam

Which ones do you need?

To get a better understanding of the problem you are experiencing we need more information from you. Please see http://osmc.tv/wiki/general/how-to-submit-a-useful-support-request/ for advice on how to help us.

1 Like

Just tried it now but keep getting error about message length. I think size of logs is too big.
Am i right?

disable debugging.
reboot twice
enable debugging
reboot
upload logs

Here:

- CaNsA

After reboot, waited for a minute or so then unplugged LAN, navigated to MyOSMC to check wifi availability and then plugged LAN back in to upload logs.

Yeah… you might want to try removing all the “grey area” streaming addons and repos.

Probs best to start from a fresh install.

I do not see dmesg in your log, which is the log I need to see.

Issue is identified. I added the SDIO firmware but it did not end up in Git (forgot to rebase). I will push that out now and it will be available shortly.

Sam

1 Like