Raspberry pi 3b - sound volume is too low

#1

Hello,

I have issues with sound volume. The device is far too quiet. I realized this today. It is not related to the media file I am playing. I tried a few files and the issue exists also for files that I played in the past without any issue.

To be able to hear sound I have to change the volume of my TV nearly to 100, a few days ago I always used 14-20 as setting.

I am not aware of any changed configuration (April update was already installed and is not the reason for the change). The only thing what I did today different compared to yesterday is that I used my iPhone to stream sound to KODI (AirPlay). I have the feeling that this changed something.

I already did a full restart of the box and TV.

The issue does not exist with normal TV which I watch via another box which is also connected via HDMI.

I already went to the sound settings and reset them to default values.

Device: raspberry PI 3b
OSMC: 2019.04-1

Thanks a lot.
Tombar

#2

I found the issue. Root cause was really AirPlay…looks like that OSMC or KODI remembers the last sound setting that comes via AirPlay.
After connecting AirPlay again and changing the volume settings to maximum via my iPhone I had normal sound volume in KODI.

I would classify this as bug because sound setting should be reset after AirPlay streaming ended.

Thanks
Tombar

#3

But what would you reset it to? Isn’t this just like having different devices feed your amplifier and having to adjust the volume a bit when you switch source?

#4

the issue is that within KODI I have not seen any possibility to change the volume. I am not talking about resetting the volume of TV.
AirPlay has somehow changed some KODI settings and after ending AirPlay the volume settings cannot be changed any more…I was only able to reset the volume to normal by re-starting AirPlay and changing it.

#5

What have you tried to change the volume? Do you have volume buttons on your remote? Are you just saying they don’t work?

#6

The volume buttons on my remote directly change the volume of the TV (no influence on KODI). The raspberry is connected to a Samsung TV and I am using the Samsung remote to control OSMC/KODI via HDMI-CEC.
But it seems that if volume is changed in AirPlay mode on the iPhone the volumn is adjusted directly within OSMC/KODI and not on the TV.

I tried to find a volume setting within the KODI settings to reset/change the volume after AirPlay was disconnected. But I failed to find such a setting, therefore I mentioned that a reset is required after disconnecting AirPlay.

#7

The only way to adjust Kodi’s volume if you don’t have a direct connection between your remote and the Pi is via the context menu when playing a video. Why that’s not available when playing music I don’t know.

#8

Or via the Web control of Kodi (eg via Yatse)