Raspberry Pi 4 display turns off after booting up with Nov2021 update

(I was originally going to glom this onto one of the other Raspberry Pi/November 2021 threads, but the symptoms seem a little different.)

After updating from the August 2021 release to the November 2021 release on my Raspberry Pi 4, I started having an issue with the display going blank on boot up. The last thing I see is the initial text output (about mounting the SD card and such), then the screen goes blank. Unplugging and plugging back in the HDMI connector gets it working again with the normal Kodi UI. I’m using the official RPi4 power supply (https://www.raspberrypi.com/products/type-c-power-supply/) and everything was working fine on reboots before the update. The only USB device being powered is the OSMC remote dongle. The TV was originally plugged into HDMI1 on the Pi and I tried swapping to HDMI0, but it didn’t seem to make a difference.
The normal way to poke at display information on a Pi (tvservice) doesn’t seem to be working in OSMC:

# tvservice -S
tvservice is not supported when using the vc4-kms-v3d driver.
Similar features are available with standard linux tools
such as modetest from libdrm-tests.

I was afraid to install libdrm-tests as it only exists in buster-backports and wanted to upgrade libdrm stuff out from under osmc as a dependency.

You can upload logs via grab-logs -A that should also include some EDID info.
So after you replug the HDMI there is no issue with the picture even when playing movies? So only related to after booting?

Right, there’s no issue with playback after getting the display functioning. Looks like as long as the TV is connected or turned on after boot, things work like reconnecting the cable did (turning TV off and then on again after boot, or leaving it off until after boot has completed both work around the issue). My TV is just a dinky old 720p Vizio TV.
Logs before:
https://paste.osmc.tv/batihazise
Logs after turning TV on/off:
https://paste.osmc.tv/nihiceyako
(No notable difference.)

I applied the latest update today and confirm the same issue reported by Xiche.

My logs have been uploaded to:
https://paste.osmc.tv/zepuruhowe

Noted as well that unplugging/plugging in HDMI cable to Rpi4 causing black screen after a reboot. Can ssh into osmc host.

Issue is same when plugged into Samsung Smart TV and into gateway 1920x1200 Monitor different HDMI cables. Worked solid before this upgrade.