Raspberry pi 4 no video after boot

I’ve been running into this for awhile but previously just gave up and thought I misconfigured something so I reformatted and reinstalled. This seemed to fix the issue for a short time but then it returned.

This is a fresh install of OSMC and it works fine for a day or so but eventually the Raspberry Pi begins turning on the TV via CEC every few minutes. This happened in the middle of the night so I just turned off the Pi (using the command from Yatse on my phone). The next day I turn on the Pi and I get the boot splash screen, then it goes blank - no signal. I’ve reinstalled a couple times, tried older versions when installing but it seems to eventually end up this way. If I install VNC server on it (using the script from here) then it will output video after boot but it’s just the VNC display - no sound and limited resolutions.

I’m not sure what else to do or why this keeps happening. Here are the logs I collected if it’s useful:

Read this

The Soundproblem is solved script allready updated, look @ this you can manual add this to the /boot/config-user.txt


What did you mean with limited resolution, on the Screen or the VNC window?

Thanks for this - playing around with some of the settings I was able to get it showing the Kodi interface again but whenever I try to play media it switches to an unsupported resolution and goes black. When I stop playback the GUI appears again. If I go into whitelist the resolutions that will work on the display, when I then try to play something it just freezes on the GUI, but I can see the media playing via my phone on Yatse - stopping playback reloads the GUI again.

Maybe it’s the cable I’m using but it’s obviously not detecting the supported resolutions and outputting incompatible ones seems to be the main issue. I don’t have another cable to test with but I’ve tried 2 different displays. Not sure what else to do to get it to display properly, I’m not using a 4k display, I just want it to play 1080p and 720p resolutions normally. Shouldn’t it be possible as a workaround to whitelist supported resolutions and get it to actually display media properly?

I mostly used the VNC script as a test to see if it would output, but when I enabled the VNC service it would only give me up to 1024x768 resolution on the display - I wasn’t using VNC, it was only the connected display output.