Raspberry Pi 4 - Sad Face Loop

Hi there! I have a Raspberry Pi 4 (4gb model), I tried using the OSMC installer to put the latest on a 16GB Micro SD. When I boot up the Pi with SD inserted, installation completes without error, then on the first reboot I get a sad face screen. Then every 5-10 seconds it reboots again to sad face. It does this perpetually.


  • This is a completely fresh install of OSMC
  • I have tried November, October, and September releases all of which failed
  • I’ve tried OSMC installer AND the Raspberry Imager, both fail
  • I am using the recommended 3A Raspberry plug
  • I tried with and without Keyboard plugged in, fails regardless
  • I have nothing else plugged in (just SD card, monitor, and power)
  • Raspberry firmware is up-to-date, and before this I had the Pi OS running fine on the system without issue
  • I’ve tried using SD card to install the OS to a USB3, still fails
  • I’ve tried a different 32 GB SD card, still fails

Any ideas?

The sad face means Kodi crashes. Do you see the Installation screen where you choose the language and can activate SSH?
If so you could activate SSH and then login when you see the sad face.

Then you could upload logs via grab-logs -A

That maybe can give an idea what goes wrong.