Raspberry Pi 4 shuts off screen shortly after OSMC logo

I successfully updated my raspberry pi OSMC from the August update to the latest November update, but after reboot I can’t access OSMC again. Shortly after the OSMC logo I get a No Signal on my TV.

what can I do?


After removing my attached external USB hard drive I can now boot into OSMC. if I reconnect the hard drive I get back into the No signal state again.

here’s my log log;


Your power supply is probably not good enough.
Is the HDD externally powered?

1 Like

This only happens with the November Update, I’ve tried another microSD with the August Update and I can boot fine with the HDD plugged in.

The HDD is not externally powered.

Even without the HDD the system shuts off the display after a few minutes and I get the No Signal issue with the November Update. When this happens the Raspberry Pi will be way too hot.

I think this will be your problem.
If the Pi is fine without it attached, then it’s not an OSMC issue.

Let me get another power supply and test…

Thanks @sam_nazarko , I tried with my 33W USB type C adaptor and it’s working fine. I had an 18W and that was the problem.

Thanks :smiley:

I’m glad to hear this is now working as expected.

1 Like

looks like the update made Kodi use more power, If I run the August update the raspberry pi 4 runs fine though there’s occasional “under voltage detection” warnings usually at boot up or when shutting down.

I’m not sure if there’s a glitch with this update I can see the bottom part of my TV screen flick.

Then your PSU was never sufficient in the first place.
For external drives, consider a powered hub, such as 4 Port USB 3.0 Powered Hub - OSMC.

1 Like

Occasionally i see this too since November’s update. A distorted horizontal bar in the lower part. Just a flicker and happens only in the GUI.