Raspberry Pi B+ 1.2v image not booting on different variations

I have purchased two batches of Raspberry Pi B+ v1.2.

One i purchased a few months ago, the other i purchased last week.

I have put an image on an micro SD card and put it in both of the Pi batches, the first batch i purchased boots fine.

However the new batch does not boot at all.

Looking at the PCB designs they seem to be the same apart from the large centre chip.

Any help would be appreciated.

provide front and rear pics of both devices

Boards that work:

Boards that dont work

That looks ok (maybe @popcornmix can take a quick look).

So you write [quote=“KirkmanJ, post:1, topic:18404”]
However the new batch does not boot at all.

So what is happening (when you put the same card that is working in the other into that batch? Black screen? Nothing on the screen at all? What are the LED’s doing (check from the first moment you attach the power.

Screen black, no signs of life.

POW constant Red.

ACT Flashing Green.

Try installing first on Batch 1, then moving the SD card over to Batch 2. It’s possible target installer needs a firmware bump. Currently we use firmware 9cd1c6c0e03ac5497b2972e5a45cb6150529150e.

Could also be worth checking that the new Pi actually work with the vanilla Rasbian OS. It might (although unlikely) just be a bad Pi.

was one of my first thoughts jb, so i tried several of the new batch, none worked.

Currently getting the latest NOOB update ( as it has been recognised by the Pi ) to see if that can get one to work.

Been wondering, my image was created end of last year ( November - December time) has the Pi’s been updated to a point my image would no longer work?

Probably new RAM. I think ELPIDA was introduced with Pi Zero. A newer image should work fine.