Raspberry Pi Fresh Install Wired No Internet

I’m having a problem with DHCP and wired ethernet on a fresh install of OSMC. I’ve installed RC3, the 2015.06-1 release, and even tried RC1, and none of them can seem to figure out how to get an IP address via DHCP. This installation is a clean install over a fully functioning Raspbmc install. I have not changed any settings from the stock install on any of these images.
During the setup that occurs at the first login, the network says it’s not connected. No amount of fiddling with turning the adapter on/off, trying to set a static ip, etc has any effect. Selecting the option to configure the network later also doesn’t make a difference.
To verify that I hadn’t spontaneously had an issue with the network or network cable, I plugged my laptop into the same ethernet cable, and everything is fine. Also, this worked in raspbmc this morning on the exact same hardware setup.
Can anyone please try to help me solve this? I went from a functioning system to one that can’t even see my network.


Two more bits of information: This is a USB install, and I have a non-standard IP Address schema. Would either of these cause the issue that I’m seeing?

Can you explain what your non-standard schema involves?
There might be clues in the logs. I realise you cannot post them directly - but there is an option to save them to a file, and you could export this file and post it using another machine.

My home network hands out 200.200.0.X addresses, instead of the more standard 192.168.0.X. I’ll see if I can retrieve the logs…thanks for the suggestion.

Uhhhhhh, why ??

You have something against RFC1918 ?

So, do you have any right to use this IP range owned by Embratel-empresa Brasileira De TelecomunicaÇÕes Sa

You should use 192.168.x.x or the one that your router recommends.

Please change to the correct scheme, and get back to us… We have a hard time helping if your network is not set correctly.

Guys, re-provisioning my network isn’t a viable or reasonable solution. Perhaps we can re-focus on figuring out why this has worked for years on raspbmc, and why it doesn’t work on osmc?

Perhaps these entries could have something to do with it?

Jan 01 00:00:15 osmc networking[156]: Configuring network interfaces…warning: couldn’t open interfaces file “/etc/network/interfaces”
Jan 01 00:00:15 osmc networking[156]: warning: couldn’t open interfaces file “/etc/network/interfaces”
Jan 01 00:00:15 osmc networking[156]: warning: couldn’t open interfaces file “/etc/network/interfaces”

Jan 01 00:00:18 osmc avahi-daemon[238]: chroot.c: open() failed: No such file or directory
Jan 01 00:00:18 osmc avahi-daemon[227]: Failed to open /etc/resolv.conf: Invalid argument


Full logs please, not snippets.

Use the log uploader to capture all logs and choose the option to save to disk - this will save a combined log in the fat /boot partition, then paste it from your PC (using an SD card reader) to paste.osmc.io

We don’t use /etc/network/interfaces in OSMC so that is not related to your problem.

Here’s the full set of logs.



I see you have a USB flash drive and a USB hub with a Logitech keyboard receiver, and a Flirc plugged in. Is the USB hub powered, or being powered off the Pi itself ?

Can you try booting without these extra USB devices disconnected ? The Ethernet interface is often the first thing to stop working if the voltage is too low due to excessive power drawn by devices.

Also what happens if you manually configure your IP addressing in My OSMC, Networking - does it work then ? That would help confirm whether it is only a DHCP issue or whether there is an Ethernet problem.

The usb hub is powered, and powers the pi.

I have removed the powered hub, flirc, and usb drive that I had previously installed the OS to. I have the OS installed on the SD card, and only the receiver for my wireless keyboard plugged directly into the Pi. Without the other USB peripherals I was still unable to establish a network connection.
As suggested, I tried configuring a specific IP address in My OSMC, which was also unsuccessful.

I verified once again that the ethernet cable is good, as my laptop works fine plugged into it.

I enabled debugging, and have pasted the most recent set of logs here: http://paste.osmc.io/uhozewaduk.vhdl


Can’t really see anything wrong in the log I’m afraid, I can see the following address being configured:

Jan 01 00:10:54 osmc connmand[228]: eth0 {add} address label eth0 family 2
Jan 01 00:10:54 osmc connmand[228]: eth0 {add} route gw scope 253 <LINK>
Jan 01 00:10:54 osmc connmand[228]: eth0 {add} route gw scope 253 <LINK>
Jan 01 00:10:54 osmc connmand[228]: eth0 {add} route gw scope 0 <UNIVERSE>

And you definitely cannot ping this address from another machine ?

One comment I would make - is your local network really using a /16 subnet mask ? And you are behind a NAT router ?

If so, every internet address from to will be inaccessible to you, even on your other devices that are “working”…

I think you’re just going to have to try plugging it into a different network with normal IP addressing to see if that is the issue or not as there’s nothing further I can suggest you try, especially given your crazy network addressing… :wink:

ConnMan will not support this:

         * Return the next IP block within the private IP range
         * 16-bit block –
         * 20-bit block –
         * 24-bit block –

Use one of the RFC compliant ranges that ConnMan expects above.


It took all day, but I reworked my home network, and now connman is allowing ethernet to work. Thanks to everyone for pitching in and figuring out what had changed to cause this to start failing.