Raspberry Pi some video not playing

Hi all,

I just installed OSMC on my raspberry pi 3 b+, and I’m having trouble playing video files. When I select some video files from my external USB drive to play, OSMC pops up with a loading icon in the center of the screen, which then freezes and the audio from the video starts playing. I can exit out of the loading screen with esc, and navigate around as I usually would while a video is playing, I can even pause and restart the video and it pauses and restarts the audio. But if I try to return to the video it just freezes the screen until I press esc again. If I pause the video playback it shows the control bar with timestamp and playbar and everything, I can even set subtitles and everything. The subtitles do not show up. I’ve tried this with h.264 mp4s, h.265 mp4s, and mkvs, and it appears to happen on h.265 mp4s and not h.264 mp4s (which seem to play normally), and has happened with some of the mkvs, but some mkvs it doesn’t happen to. I’ve tried the same video files with LibreELEC and that can play them just fine. Any enlightenment y’all have would be much appreciated…


I should also say, I’ve tried this with the 2023.01-1 version of OSMC as well as the 2022.09-1 version, both have the same problem.

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device twice(!)

  • reproduce the issue

  • upload the log set (all configs and logs!) either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:


HEVC isn’t supported on Pi 2 /3 on newer versions of Kodi.
This is explained here: Kodi v19 Matrix is here. Here's what you need to know - OSMC.

The same will apply to the latest versions of LibreELEC which use Kodi v19 or later. You can use an older version.

Alright, thanks. Where can I find an older version of OSMC? Looking at the downloads page the oldest version I see is from 2022, is there an archive somewhere?