Raspberry pi2: Crash when connecting External USB drive

Hi there,

a very strange thing happening: suddenly after more than 1y of usage as soon as I connect an external USB HD to Raspi2 OSMC crashes.
Crash is not at Kodi level but lower as if I am connected with SSH also basic commands are broken (ls, df, etc…).

USB drive is connected through a powered USB HUB: i tested 2 Hubs (1 brand new) and HD on 2 separate system with no problem, thus i would rule out the problem stays in one of the two.

Here
http://paste.osmc.io/ijanuzezum

you can find the log file

To get a better understanding of the problem you are experiencing we need more information from you. Please see http://osmc.tv/wiki/general/how-to-submit-a-useful-support-request/ for advice on how to help us.

Hi CaNsA,

you were actually too quick and I hit Send button accidentally!
attached the link to the log file

What happens when:-
You use a dedicated power supply?
You disable transmission?

Nothing obvious in the log file - if the log wasn’t taken after the issue occurred it’s unlikely to show the problem.

I notice you are using a USB install - if your whole system stops responding properly when you connect the second drive the obvious conclusion is that connecting the second drive is causing a problem accessing the first drive.

Are both drives sharing the same USB hub ?

Hi guys,
I will try to reply both.
The USB hub uses a dedicated power supply and the strange thing is the same setup worked with no problems for at least 1 year.

The os USB drive is connected directly to the RPI, while the HD to the HUB.

I grabbed the log after the issue, isn’t it showing anything strange?
As I can replicate the problem how should I do to make it visible on the logs?

If you power the pi from a dedicated power supply other than this hub does the issue persist?

I really don’t think this is a software issue at this point.

RPI is powered by a dedicated power supply already (actually official RPi2 power supply)

Ciao guys,

I did some further test: if I power up the PI with USB hub and hd not connected it works flawlessly.
If I connect hd and hub I get a message of unsafe removal (it is not a typo what I wrote): at this stage if I do for example video/file in osmc I have a big system crash and I have to unplug power from RPI.

I am really not in SW but it seems the problem occurs when it tries to access HD?

Also I modified in the past /etc/fstab to have the proper setting for HD mounting: I tried to remove the line hoping it was the problem (again it has been like this since months) but with no success.

Transmission has been installed in the past separately from CLI and not from myOSMC app service.

Are there other tests/info I can provide?

I did other tests:

  • format the USB drive both Fat32 and EXT4 to make sure there was no some corruption on the drive itself --> no joy
  • tried to update the log after the crash but before rebooting the device: unluckily as soon as the HD is connected everything crash thus i can’t perform any command though SSH

I have a spare 8Gb microSD card: should i try to re-install latest OSMC from scratch to rule out potential SW problems?