Raspberry pi2 loads with Samsung, but not Vizio


Raspberry/ osmc loads works great on my Samsung montior (36 inch)…but when I try using the Vizio tv (50 inch screen) I just get a black screen…I have tried using different hdmi cords and inputs ( 1 or 2 or 3) tired having tv on and then power on the raspberry/osmc …and having raspberry/osmc on then turning on tv

but raspberry/osmc works great on the Samsung monitor

Please advise.

I assume that the TV is turned on before the Pi is booted ?

Please try logging into the Pi using SSH when connected to the TV that is giving you no picture, and post the output of the following three commands:

tvservice -s
tvservice -m CEA
tvservice -m DMT

once i log on via ssh - where do i need to go to add these 3 commands?
I will have time tomorrow morning to work on this and see what happens…

Thank-you for your advise and time.

You issue those commands from where you login (osmc home)

Thanks- I did - but missed a step…

Your problem is that your TV is not sending EDID data to the Pi - it is not listing any CEA or DMT modes therefore the Pi boots in a default 640x480 which apparently your TV can’t display.

Have you tried a different HDMI cable and/or tried using a different HDMI port on your TV ? This is very likely a problem with the HDMI cable.

I will have time tomorrow after 5pm California time to test out the solutions. I really want to say thank-you for your help !

I just got home and changed hdmi cord from flat high speed hdmi cable with ethernet to the round cable which came with raspberry pi 2 (OSMC direct) - works great !!

Thanks for the great support.