Raspbery Pi4 Kodi v19 Remote Control, PiConfig

I installed the latest Kodi version (v19) on an RPi4 and did an OSMC update. Much works excellent, however I have two main problems:

My remote control, which works fine on the RPi3 (Lircd full, GPIO pin 18) shows no function on the RPi4. All other remote control settings do not work either.

I can’t access the PiConfig in OSMC.

Smaller problems concern the 3D playback in SbS or Hou. There is no switching to the correct mode. As read 3D-ISO-Files only Play in 2D :frowning:

Maybe someone has a suggestion for the configuration of the remote. Would be pleased.

Greetings to the developers.

WRT the remote control problem, please provide full logs. (Kodi debug logging not required.)

I have uploaded:

I noticed this in /boot/config.txt:

# Warning: do not edit this file, or it could prevent your OSMC system from starting.
# If you wish to make changes, you should do so via My OSMC or edit the config-user.txt file in this directory

So if you have included any instructions in /boot/config.txt, eg dtoverlay, they need to be moved out to /boot/config-user.txt.

Hello, first of all thank you for the quick answers. I installed the system directly from the OSMC image and did not change anything. I would not even know how to change a text file inside OSMC.

Do you recall how you configured the Pi3? If it involved the PiConfig screen, you might need to update one or two files manually.

That was also my thought. My Pi3 is still running in parallel. Unfortunately, the Config menu can not be opened on the Pi4. A problem that has been described several times in the forum.

  1. If you can see what you did on the Pi3, then we should be able to re-create the same settings on the Pi4. So do you remember how you configured the Pi3?
  2. Please supply full logs for the Pi3 (Kodi debugging not required). How to submit a useful support request - General - OSMC

Hi, I have now also uploaded the logs of my Pi3. Maybe you actually have the possibility to find the error. Anyway, when I click on Pi Config, nothing happens at all (despite the latest update).
Thanks, kaernesto


In the meantime, new error messages are coming in:
Often the error message “OSMC service is unavailable” appears when I try to start the OSMC app and when I try to update OSMC manually, the process aborts with the following error message: “addon error - View log file for more information”.

You’ll need to create a file /boot/config-user.txt and add two lines to it:


(I’m not sure if the first line is necessary, but it doesn’t stop the Pi4 from starting.)

You’ll need to SSH to the device and use the nano editor. Copy/paste the above lines.

Run reboot from the command line, wait for the device to restart, and see if the remote works,

can confirm Pi config is not working, unsure on the other issues, fresh install of OSMC. rpi 4

Thanks for the tip! I created the config-user.txt file, but unfortunately in the Home/Boot folder. In OSMC filemanager the file can not be moved to the root/boot directory (“error”) and via Putty in Windows I can not get to the root directory :frowning:

sudo nano /boot/config-user.txt
Add the lines and then Ctrl-x - y - Enter

The problem is solved: I got into the root directory with “sudo -s” and created the boot/user-config.txt file there as dillthedog suggested. the tip was spot on - the remote works. Thanks a lot :pray:

And suddenly the PiConfig works too :star_struck:

1 Like