Rasperry Pi home dir restore

Hello guys, this is Daniele from Italy

I’ve been using osmc in my raspberry pi 3.
I installed “imagemagick” tool (sudo apt-get install imagemagick), all seems good and I ran identify and other imagemagick command.

The issue: the day after (I can’t remember if I reboot pi or not) I cannot find imagemagick and the its command, also my home dir seems restored as it was before the install (I made a script to rename the jpeg file adding some info to the name, it was in my home dir and now is totally disappeared).

I tried to re-install imagemagick, but I still have the same issue.

Any suggestion? Thanks in advance,


That indicates your SD card most likely gone.
Do this test:
touch test.file
ls -lah test.file
ls -lah test.file

If your test.file is not visible after reboot get a new SD Card.

You are right, thank you so much, test.file is missing…

I will replace the SD as soon as possible, do you think that if I made a SD backup now it may be somehow affected/corrupted?

Hard to say but it might be still OK. Just do the backup and restore on the new card. You don’t have anything to loose.


It seems like your SD card may be problematic.

Some SD cards are not genuine or have a lower capacity than advertised. Some simply fail over time.

Symptoms of SD cards not working correctly are:

  • Read-only behaviour, or changes made not persisting
  • A filesystem corruption error

Symptoms of counterfeit SD cards are:

  • Writing works until a certain filesystem size is reached, thereafter, writes seem to cause issues where existing data is lost or newly written data is not preserved.
  • SD card fails after a short amount of time.

Counterfeit cards are usually found on Amazon and eBay.

SD cards have a limited lifespan. I recommend you change SD card and suspect that issues will no longer persist with a good card. If you would like to be a good quality SD card purpose manufactured for OSMC, then you can find one in the Store.

Thank you all,

I have a progressive rsync log that every day syncs, the file looks good until Sept 16th.
On Sept 17th I removed the SD card (to make a backup), the issue started there.