Raspi 2 - libc6_2.28-110.4 upgrade issue


I’m trying to update from OSMC 2021.11 to the latest version 2022.03 but getting following errors on my Raspi 2 (Vero 4k worked fine)

sudo apt-get update
sudo apt-get dist-upgrade

BEGIN failed–compilation aborted at /usr/share/debconf/frontend line 6.
dpkg: error processing archive /var/cache/apt/archives/libc6_2.28-110.4_armhf.deb (–unpack):
new libc6:armhf package pre-installation script subprocess returned error exit status 255
Errors were encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)

sudo dpkg --configure -a
Setting up linux-libc-dev:armhf (4.19.232-1) …
dpkg: dependency problems prevent configuration of libc6-dev:armhf:
libc6-dev:armhf depends on libc6 (= 2.28-110.4); however:
Version of libc6:armhf on system is 2.28-110.1.

dpkg: error processing package libc6-dev:armhf (–configure):
dependency problems - leaving unconfigured
Setting up libc-dev-bin (2.28-110.4) …
Processing triggers for libc-bin (2.28-110.1) …
Errors were encountered while processing:

any ideas how to resolve this installation issue?

kind regards,


To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device twice(!)

  • reproduce the issue

  • upload the log set (all configs and logs!) either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:


I just uploaded the log files for this issue.


thanks in advance,



Looks like perls base install is corrupt, please:

sudo apt-get --fix-broken --reinstall install perl-base libperl5.28

Thanks Tom.

Perl is a large package and one of the most likely packages to be corrupted if an SD becomes problematic because it consists of so many files.

It seems like your SD card may be problematic.

Some SD cards are not genuine or have a lower capacity than advertised. Some simply fail over time.

Symptoms of SD cards not working correctly are:

  • Read-only behaviour, or changes made not persisting
  • A filesystem corruption error

Symptoms of counterfeit SD cards are:

  • Writing works until a certain filesystem size is reached, thereafter, writes seem to cause issues where existing data is lost or newly written data is not preserved.
  • SD card fails after a short amount of time.

Counterfeit cards are usually found on Amazon and eBay.

SD cards have a limited lifespan. I recommend you change SD card and suspect that issues will no longer persist with a good card. If you would like to be a good quality SD card purpose manufactured for OSMC, then you can find one in the Store.


thanks for the tip. Tried the command but doesn’t work:

osmc@kodi:~$ sudo apt-get --fix-broken --reinstall install perl-base libperl5.28
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
 libc6-dev : Depends: libc6 (= 2.28-110.4) but 2.28-110.1 is to be installed
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).


sudo apt --fix-broken install

doesn’t work

Maybe the fastest way is to reinstall from scratch with a new SD card as suggested by Sam





Thanks Tom.