Raspi2 after Juli/Aug'15 update: Fast Forward or Skip picture freeze while sound is okay

After I updated my Raspi 2 B around August 23rd, I am not longer able to FF / Skip time some “SD” movies.

What happens?

  1. While the sound is coming clearly and seem to be of right time stamp after each jump or after returning to normal play, the picture is allways freezed at 00:00:30.
  2. my wife makes my life hell, for the same reason

This issue sounds a bit like “Vero Freeze” forum topic, but I’m uncertain, if it is the same, because:

  • Before updating OSMC, FF/Skip worked well with previous OSMC.
  • same “SD” movies on my two other Pi 1B devices can FF/FB/Skip, all doing well (KODI-Raspbmc)
  • with some “HD” movies of different video type, it still works, also with recent OSMC !?

Note: what I name “previous OSMC” is “OSMC_TGT_rbp2_20150628.img.gz”, which was installed by “osmc-installer_20150705.exe”.
what I name “recent OSMC” or “August Update”, is what I got via apt-get … dist-upgrade and via “myOSMC: download and install update automatically” on August 23rd 2015 (before 23rd, I had disabled automatic install).
(Please lead me to the places, where I can find the recent configuration identifier. I only know ssh + uname -a so far)

Some more facts on what I did:

  • The “SD” Videos have been recorded by TVHeadend from German DVB-T
  • The Remote is CEC

Crosscheck #1 (other Raspi devices):
With an older release and older hardware, the same movie files are working well. In detail, it is Raspi 2B and Raspi 2B+, both running KODI from around Easter 2015 under Raspbmc from around Easter 2015.
I used the identical SMB/CIFS share with identical user credentials of identical Linux-Server to eleminate side effects (14.04-LTS, running TVHeadend and CIFS server).

Crosscheck #2 (other video material with all 3 raspi Devices):
I downloaded “HD” material of same TV broadcasting station (via “Mediathekview” linux desktop application). It does FF/FB/skip well on all my raspis, including the OSMC/Raspi2. But aside of the higher resolution, these movies are of a complete different video file format and encoding, I guess.

My Setup was “all default” + then changed to:

  • 1080p50
  • German
  • changed Skin to Confluence, since it’s selection marker/highlighting is more readable to bad eyes.
  • Samba-Shares to Xubuntu 14.04 LTS CIFS server in the same network (GB Ethernet wired)
  • TVHeadend plugin to a remote TVHeadend server in the same network (GB Ethernet wired)
  • sound allways via HDMI, passthrough.
  • I inserted a Ligawo HDMI/Toslink splitter for the amplifier (as used with all other Raspis)
  • I added a Samsung TV (as used with all other Raspis, but each has a different generation of Samsung TV)
  • changed myOSMC: download and install update automatically on 23rd August

I Hope in a first step, you can give me orders how and what files I have to collect and upload (version information, setup and logs, video file format dump, …?).
I’m not a complete noob, but a medium experienced Debian user since 5 years, and still kind of a XBMC/KODI/OSMC newbie :wink:

Thank you in advance

Is video software decoded? If so see: Video freezes after seeking
If codec overlay shows “ff-” then it is software decoded.
(Or post debug log or mediainfo of file).

Argh! You got me!
This is the only Raspberry device that I use without the MPEG key. Just because it worked so far because of high CPU performance of the Pi 2.

Okay, I just ordered the key(s) at raspberrypi.org and then I’ll let you all know, if this fixed my problem.

It is still 5,15€ for both decoders. Same price as for the Pi 1

I’m experiencing the exact same issue and it seems I also forgot to set the license key after a complete reinstall of OSMC.
Have set it now. If the problem is not solved I’ll come post another message…

@popcornmix, it fixed my problem.
Just inserted the keys 2 hours before (ssh + sudo -i + nano /boot/config.txt + reboot) and tried skipping, ff, fb - all working well now.

@cyberschlumpf, wat do you get on the following commands?
vcgencmd codec_enabled MPG2
vcgencmd codec_enabled WVC1
(IMHO, you do not need VC-1 codec for German DVB-T)

Hi, MPG2 is disabled currently, as expected. I had to completly reinstall OSMC a week ago,because I had an endless crash loop during boot after the last update.

And: yes, I only have the MPG2 codec. VC1 is mainly needed for Blurays, which I don’t use with KODI

@cyberschlumpf the stall on seek with software decoders should be fixed in Sunday’s OSMC update.
Have you updated and do you still have the problem?

Hi popcornmix,

hm, I have the unattended installation of updates configured and am only notified im a reboot is pending.
There was no message on the screen yesterday evening and the problem still occurred last evening at about 8 p.m.

Is there a precise version information somewhere in OSMC? Or is the version string in the OSMC app the most precise one?

I"ve now re-entered my license key and so far no problems.

Also, is there a detailed changelog somewhere what has been changed in each new version of OSMC?