Raspi3B+ not working after update


I just got the Raspberry PI 3B+ and I wanted to try OSMC out. I updated it through my Raspberry PI 3B, which all went successful, but when I plugged it into my 3B+, I’m confronted with that colorful boot image, and it won’t continue.

It does still boot when I put the micro sd card into my 3B.

Any suggestions on how to fix this?


Try updating again via myosmc and make sure there are no outstanding updates.

Thanks Tom.

Hi Tom,

I just tried and according to myosmc there are no updates available.


If you could provide logs, it may give insight.

Unfortunately by 3B+, has yet to arrive; so I can’t test myself.

Thanks Tom.

Which logs would you like me to provide? I highly doubt that the OSMC or Raspberry logs have anything as it won’t go further than the test pattern by start.elf.


Logs from when its Raspberry PI 3B:

grablogs -A

Thanks Tom.

Here is the link after running “grab-logs -A”: https://paste.osmc.tv/bifodiseca

deb http://apt.osmc.tv krypton main

Remove this from your sources.list. Update and dist-upgrade again.

Unfortunately, that didn’t work either.

One thing I did notice is that none of my micro sd cards work in the 3B+, except one that I put the latest NOOBS on to try out.

Compare a listing of the FAT partition /boot - file names and sizes - between the booting noobs SD and the non-working updated one

Updating to the staging repository will definitely make sure you are up to date.

  1. Login via the command line
  2. Edit the file /etc/apt/sources.list
  3. Add the following line: deb http://apt.osmc.tv stretch-devel main
  4. Run the following commands to update: sudo apt-get update && sudo apt-get dist-upgrade && reboot
  5. Your system should have have received the update.

Please see if the issue is resolved.

I also recommend you edit /etc/apt/sources.list again and remove the line that you added after updating. This will return you to the normal update channel.


1 Like

I indeed went up a version, according to myosmc, but when I try to boot it using the 3B+ it still doesn’t go any further than the test pattern.

I’d suggest waiting for the installer image to be published on the OSMC website then as other users have reported success when updating


Also make sure you are not using NOOBS. Older versions of NOOBS have firmware that is too old


Yeah, I guessed that just now. I did an override of the old NOOBS and now its at least booting into NOOBS. Do you know a way to just update NOOBS without it clearing the rest of the micro sd so I can get it back up and running?

You should ask where ever NOOBS developers offer their support.