RaspPi 1 IR remote help

I know this topic gets thrown up here a lot but reading them gets me lost. I need step by step instructions for this please, beginning to end. I have the Raspberry pi 1 and an HP media center remote with the IR sensor. Shown in pic. I tried to select all remotes available in OSMC but none of them work. I see topics on how to program your own but don’t know where to go to type in command lines. I also see you can move Lirc config but do not know how to move LIRC.config file. Please help once again beginner. thank you

So you ripped the ir module out of an old HP desktop and have that sitting next to a raspberry pi not connected in any way and figured that somehow finding the correct software settings should work?

I just wanted to show you what I had. I bought the remote and IR sensor off eBay years ago and it came with instructions but I lost them. It was working up until two weeks ago with the remote until I got the startup splash screen on OSMC. Downloaded the latest version booted it up and tried to get the remote to work again but don’t know how.

When you were in the remote section of the My OSMC add-on did you click on the remote name after you highlighted it and then accept the confirmation before the timer ran down? I seem to recall those were just rebadged MCE and so it should work with the rc6-mce-lircd option.

I have, I selected it confirmed then restarted for it to take effect but it doesn’t work. I will try again just to make sure though

It might also be an MCE remote that does not support rc6, so you have to disable that in the MyOSMC remote settings. I have a Hauppauge MCE remote like that.

But how did you connect it to the Pi (GPIO) and have you configured the right pin?

It has a female end that fits right over the GIPO, it’s one piece. Kinda just plug and play. It worked with the last OSMC program. I get the red light every time I press a button on my remote but the remote doesn’t work yet on my Pi.

So can you see to which GPIO pin the TX goes? And then reconfirm in MyOSMC -> Pi Config that the same TX pin is set.

I will check that out

Everything registered saying it works. Plus the light works every time you use an Ir remote around it. I just need help on how to either type in the command lines and where to go to type them in at or how to move the Lirc.config file

I am lost with your reply. So which GPIO is used and which one is configured?

Sorry for not replying, but as soon as I read what you meant by your response I realized I had to activate the pin in Piconfig menu. Thank you so much and once again sorry for an extremely late response.

1 Like