RBP2 Issued a Fatal Error when mounting a file it did not find

Hi, I’m a 75 year-old newbie in both RBP2 and Kodi/OSMC; so please, be kind to me as I do not know how to communicate well regarding the isuue(s) I need to resolve. Perhaps this issue has already been resolved in this forum and I apologize for not having been able to find it.

Background: A friend gave me the RB2 already loaded a week ago. I have been able to stream a few movies albeit with much difficulty as I really don’t know/understand what I am doing. He lives overseas and is no longer available to me to look into this matter.

This evening I found the screen was not displaying the movie I downloaded and reset the video resolution. I tried other options, not knowing really what I was doing and my issue with the video output got worse.

I decided to unplug the device. On plugging it, the system displayed this message:

"Waiting for Root file system device /dev/mmcblk0p6/root-RBP2: clean, 59605/471424 files, 1061594/1884160 blocks

Mount: mounting /dev/mmcblk0p6 on real root failed; not so such file or directory".

I would appreciate it very much if one could get some information on how to resolve this issue

Thank you.

Are you saying the system is not starting up, but getting stuck on those error messages? Can you post a photo?

Do you have any way to attempt remote access to the device, like a PC?

Pulling out the plug is generally not recommended because it can corrupt the file system. I am not sure if that’s what happened here, but mount and clean errors seem odd.

Berto, Thanks for your reply.

The system was not starting up. I only received the Fatal Error message on the TV screen which I included in my first message.

After I posted the help message here, I sent my friend who got the device for me an email. I told him what had taken place and he helped me resolve the issue.

The problem was the power connection to the RBP2 was faulty. It was connected for a a few seconds but only the red light in the device was on; when properly connected, a green flashing light next to the red light and blue flashing in the WiFi should be lit. these were not. He explained that this faulty connection caused the startup but could not continue seeking files and sent the Error Message.

I made sure I plugged the power into the device well, all the lights popped up like a Xmas tree and so far it is working ok.

Issue has been solved.

Long narrative hoping it could help other facing the same issue.

Thanks for writing.


Cheers - glad you got things sorted out!