RC rpi2 won't reboot from GUI

Clean install of RC on rpi2.

nothing in my fstab except for the sdcard partitions.

Did an apt-get update and upgrade today.

Tried to reboot via yatse, and Kodi stops, but the machine doesn’t reboot.

ssh works so I issued a reboot via command line.

Which logs can I search in order to troubleshoot?

All of them.
Just use My OSMC - Log Uploader
Tick “All Configs and Logs”, upload it and paste the link here.
Edit: If you have anything specific installed, let us know. I am unable to reproduce this issue on my two Pi´s.

Thanks, will try that, but I guess the logs will be reset on reboot, so when the problem appears - kodi will be non-responsive, and after reboot the logs are reset…

Only stuff shown before reboot is in old Kodi log:

18:01:28 T:1956921344  NOTICE: ES: Stopping event server
18:01:28 T:1956921344  NOTICE: stopping zeroconf publishing
18:01:28 T:1956921344  NOTICE: Webserver: Stopping...
18:01:28 T:1956921344  NOTICE: WebServer: Stopped the webserver
18:01:28 T:1956921344  NOTICE: Webserver: Stopped...
18:01:29 T:1737163808  NOTICE: ES: UDP Event server stopped
18:01:29 T:1956921344  NOTICE: stop dvd detect media

Doh! Of course you are right, didn´t think that one through.
While you can still SSH to your Pi you can still get logs though.
Turn on debugging and try to reboot. When Kodi hangs (or whatever the issue is), SSH to Pi and run the following and post both links here:

sudo journalctl | paste-log
cat /home/osmc/.kodi/temp/kodi.log | paste-log

I will try it again with debugging on.

It worked now with a freshly restarted pi, but when it happened earlier the machine had been on for a day or two with the TV turned off a few times in between.

So my theory is that something breaks with HDMI-CEC or something like that after a while?

It’s connected directly to the TV