RC3 Image for Vero

When will the RC3 Image for Vero be ready for download

Just install RC2 and run an upgrade via My OSMC for now


Excelent suggestion, but not working.
When I try to follow got an “Installation error, Please report to forum” - what I’m doing now actually.
On Kodi restart another excelent error message - “Installation error (unknown package)”
Reboot and another update attempt have the same result.

Not nice for flagship device.

Try once more. Our site had a brief outage today


Yep, I was suspecting a network outage - I saw a big timeout during the downlod, but I mostly complain not about failed upgrade, but about that 1 network outage put Vero in permanent failure state. On a flagship device upgrade procedure have to be more robust.

And 1 more remark - I did RC3 upgrade to see if playing 3D files is fixed. It is not :frowning:


Can you explain a bit more about how the upgrade broke your device? APT (and in turn our update system) uses checksums to verify the integrity of files.

Did you initiate an update from within the OSMC interface and experience a bad upgrade?


How exactly did it put your device in “permanent failure state” ?

Did it fail to boot at all and need re-imaging ? Or are you just saying that you were unable to re-try the failed update but the system was otherwise still working ?

Also can you please use the log uploader to upload your log files in particular APT logs, so we can see exactly what happened.

1 Like

I’ve started upgrade from OSMC interface, somewhere in the middle of the download process it failed and asked me to reboot the system. I confirmed kodi restart, while restarting it gave me a message about failure in the unknown package.
It was functional, but attempts to start upgrade again were all unsuccessful - after each attempt it offers to restart Kodi, on restart complaining about unknown package.

I can not provide any logs - I reflashed it and after that upgrade went ok. Time needed for upgrade for the Vero was much longer, than for RPi B+

I’m not using Vero now due to bug in 3D playback. I still using RPi. I’ve tried to upgrade Vero only in order to check if 3D playback is fixed. So my aim was to do the upgrade as soon as possible and I do not preserved anything from the Vero before ra-flashing.

Thanks, but without any debug logs we can’t know for sure exactly what went wrong and take any steps to prevent it happening in the future. So if you see any issues with the upgrade process in future please be sure to use the log uploader to upload full debug logs and post them on the forum before wiping your install.

BTW depending on what the problem was (which we would haven seen from the log files) it was almost certainly possible to recover from the situation with just one or two commands via ssh without any re-install.