REAL basics for a new user

How do you want your movies to show up?

Like files? (In which case install the SMB Server like @fzinken mentioned)
Like an indexed movie list (In which case enable UPnP/DLNA)

Many thanks for all of your responses. Maybe my misunderstanding relates to “Media Server” and I was expecting (or thinking) “Streaming Media Server”. File sharing via SAMBA is something I do with all of my other Pi’s, that is basically file downloading, not streaming (as I understand it).

I’m looking for a system to stream files from a server device when requested by a client device. I guess OSMC is not that type of server? Thanks…RDK

If I double-click on any of my films whether it’s by SMB or UPnP/DLNA the file will play on my computer, this is being streamed over my LAN as the file resides on my Vero 4K. I don’t really understand what else you want it to do.

If you have a library setup in Kodi and you enable UPnP server as explained above then any UPnP player should pick it up whether this be a smart TV, Kodi on a PC (with the RPi added as a UPnP source), or directly though Windows 10 file manager. If you have tried doing it in Windows and you are seeing the whole file transfer before playing then you need a different player (Win10 Movies & TV app seems to work okay).

1 Like

OK folks. I give it a try again, but it seemed to me that the files were being downloaded before being played. A streamed file should start playing immediately, where a downloaded file won’t start until it is fully on the client. More later as I repeat my experiments…RDK

If we’re talking about a full bit-rate remux of a 1080p blu ray movie, downloading it completely via ethernet from a Pi 3B+ would take 10-15 minutes. Does it take 10 minutes to start playing?

If you directly open it from Windows Explorer via UPnP connection it will act like that in some (most?) players. I would guess that is just how MS implemented it to allow even non-UPnP aware players to work. You wind up with a situation that the stock default player (Movies & TV) will play it immediately but if you use VLC to directly open it the whole file transfers first. If you open VLC and open the UPnP source from playlists, which is how that app expects you to do it, then the file starts streaming right away.

With head down and hat in hand I like to apologize for my misunderstanding of how this system works. It is functioning exactly as you said and doing what I wanted. Last weekend I transferred several large video files to the USB memory stick on that Pi and then viewed them from two different Windows 10 PC’s. All worked fine. Thanks for your patience.

I did encounter one problem when transferring large files (greater that 1GB) from my Windows PC directly to the USB stick using SAMBA. In that case I had to transfer them, also via SAMBA, to my home directory on the Pi and then from the Pi’s command line move them to the USB. Any ideas about this?..RDK

1 Like

How is your USB formatted?
I think people have reported an issue currently with large files between Samba and exFAT

I formatted it on Windows 10 as FAT and OSMC command line “cat /ect/fstab” it as vfat.

I was a bit surprised that OSMC command line did not recognize “lsusb” command?

Thanks…RDK

VFAT could be one of the problematic filesystems

Nothing to be suprized, it doesn’t make sense to install all those tools by default.
sudo apt-get install usbutils will provide it.

Thanks for the info. It all makes good sense. For now I will stick with vfat as there will be several members of my family using the OSMC share and, for now, I don’t want to get tangled up in the security/permissions associated with ext4.

For big files, I use my workaround or mount the USB stick on a Windows PC for the transfer.

Thanks again…RDK

I got my new 64 GB USB3 memory stick yesterday. I tried to format it, but vfat is not an option, only ext4 and NTFS. I suppose that now access to this drive on OSMC/SAMBA will be limited by the disk ownership credentials? As I stated above I’d like to allow other members of the family to add content. Ideas?..Rob

Giving access via the network? Should be not a permission issue.

OSMC on my Pi did NOT like the 64GB USB exfat memory stick!!! Sustem crashed during a bootup.

Both my original 16 GB vfat and the new 64 GB exfat USB sticks were directly connected into the Pi. Removed the 64 GB stick and it rebooted cleanly. Is there something special I need to do to use this USA stick on my OSMC Pi?..RDK

Try NTFS. AFAIK Linux ignores NTFS permissions. This is assuming you want to keep the ability to use it in Windows without any workarounds. If your not planning on using it anywhere other than OSMC/Linux just use ext4.

Folks…I’m doing something wrong, I think. I would like to have two USB memory sticks mounted at bootup on my Pi 3B running OSMC. If I’m not mistaken the underlying OS is Stretch? The new USB 3 stick is 32 GB formatted vFAT. The old/current is USB 3 16 GB formatted vFat. OSMC seems to automount the 32 GB stick so I do see it, but I want it to be mounted as indicated below.

I have followed my normal practice for installing a USB memory stick and mounting a USB stick:

  1. ls /dev to get the USB sticks device name: in my case a USB 3 32 GB; sdb and sdb1, the other USB 3 stick (16 GB) is sda and sda1 is mounted as /mnt/usbdrive.

  2. created a mount point folder: sudo mkdir /mnt/MediaLib

  3. mount the USB stick: sudo mount /dev/sdb1 /mnt/MediaLib

  4. List the elements on the new USB stick mount: sudo ls /mnt/MediaLib
    Media Pictures System Volume Information history061420.txt
    which is, in fact, the content of the sda1 (/mnt/usbdrive) folder and not that for the new USB stick. which should be,
    ’System Volume Information’ Video

  5. I have these two lines to the /etc/fstab to mount the USB sticks, the first is for the sda1 partition and is working, second one is apparently not working
    /dev/sda1 /mnt/usbdrive vfat defaults,dmask=000,fmask=111 0 3
    /dev/sdb1 /mnt/MediaLib vfat defaults,dmask=000,fmask=111 0 4

    The results are the same for the tests in item 4. above

At the same time I have tried again to attach my new 64GB USB 3.0 xFat stick and it still crashed the OS with a message it can’t find the sda1 device.

This should all ‘just work’ and the drive should be mounted in /media for you automatically.

I’m not sure I quite understand the use-case, I know you want these accessible via the network but did you want to have the ability to move the USB sticks into other computers too?

Thanks for your reply. My issues are two fold:
1, I like my USB mounted devices to be in my /mnt folder and not in the /media folder.
2. And second, as it is working now with the second device automounted into the /media folder, I can not seem to configure SAMBA to give me full access from my Windows 10 PC. I need to be able to write, read, delete and create folders, but now it hammers me for an id and pw. This is not the case for my other USB drive. I have edited the SAMBA config files as I also did for the /mnt/usbdrive mounted device. The README in the /media folder says:
me@MediaServer:~$ cat /media/README
#### Notice ####

This directory is for automounted drives. Empty directories here are purged on reboot.

If you wish to configure an /etc/fstab mount for a drive that is attached permanently, you should do so in the /mnt directory
which is what I want to do.

In general, if I have full access to the device, it will always be attached to the OSMC Pi.

What I can not figure out is why I can not seem to mount this USB memory stick in my usual way via the /etc/fstab file entry.

USB mounting problem solved. Stupid user (me) error.

The problem with the 64GB USB 3.0 xFat stick is still unsolved. I will post it as a separate question…RDK