Really basic remote questions - volume up/down?

#12

This file uses FF/RW as volume up/down The arrow keys are 10 minute and 3 minute skips so FF and RW aren’t really needed https://dl.dropboxusercontent.com/u/30655053/osmc-remote-VOL-lircd.conf

#13

You don’t want to modify the lircd.conf file because that will affect remote functionality across all kodi screens. All you really want to do is change the function of the up and down buttons when you’re in full screen viewing mode.

#14

I finally figured out how to get it to work. Here’s what I did:

  1. SSH into the Vero (username osmc, password osmc)
  2. cp /usr/share/kodi/system/keymaps/remote.xml ~/.kodi/userdata/keymaps
  3. sudo nano ~/.kodi/userdata/keymaps/remote.xml
  4. enter osmc as password, if prompted
  5. Page down until you find the <FullScreenVideo> section
  6. Replace <up>ChapterOrBigStepForward</up> with <up>VolumeUp</up>
  7. Replace <down>ChapterOrBigStepBack</down> with <down>VolumeDown</down>
  8. Ctrl+O, then {Enter} to write the file out
  9. Ctrl+X to exit nano
  10. Sudo reboot

Test the functionality of the remote once the Vero has finished rebooting.

Cheers,
Ian

4 Likes
The new OSMC Remote
#15

@sam_nazarko can you compile a support page withe the Vero Remote default key functions ? Yesterday I take some times to understand how to modify my source or understand the difference between up/down and right/left keys during full-screen playback

#16

The Vero doesn’t have any volume options on the remote because most of our users bitstream (DTS / Dolby Digital).

Sam

And therefore a lot of us rely on CEC to adjust the volume via a receiver/amp. For me, no volume keys = useless and physical remotes are a must with children. The Vero remote is actually great in that respect; small form factor, simple layout, satisfying click, no possibility of messing up the TV/stereo/etc.

It would be great to have the option to remap the up/down buttons to volume during the installation wizard at some point. Not that editing an xml file is hard, but those sorts of details are what set the osmc user experience apart from others IMHO.

#17

You can do this via a settings file as you say. We’re looking at making it possible via the GUI soon however.

Sam

1 Like
#18

After just using vero remote i like it but i think there needs to be option to swap fastward to volume control it would then be perfect for me.

#19

Here’s one solution to controlling the volume…

Customising the Main Menu in…

Settings/Appearance/Skin/Settings/Home/Customise Home Menu.

To add a “Volume Up” menu to the main screen go to “Add”.
Now use the little “˅˄” to move the menu to the top.
Select “Set Label” and type the name “Volume Up” and “OK”.
Then select “Change Action” and this opens a new window. Scroll down to the bottom of this list and choose “Custom Shortcut >”. Type in the command “VolumeUp” and press “OK”

To add a “Volume Down” menu to the main screen go to “Add”.
Now use the little “˅˄” to move the menu to the top.
Select “Set Label” and type the name “Volume Down” and “OK”.
Then select “Change Action” and this opens a new window. Scroll down to the bottom of this list and choose “Custom Shortcut >”. Type in the command “VolumeDown” and press “OK”

Finally click the “OK” at the bottom and press the “home” button on the remote to take you back to the main menu screen.
When you select and click on the Volume menu’s they will adjust the volume.

[Solved] Vero2: Volume control via SPDIF possible?
#20

Good post… I just used it to remap fastforward/rewind to volume up and down respectively.

There’s no need to the the sudo at 3 :slight_smile:

#21

For others trying this an easier way is to edit /etc/lirc/osmc-remote-lircd.conf and change KEY_REWIND and KEY_FASTFORWARD to KEY_VOLUMEUP and KEY_VOLUMEDOWN if you save it as osmc-remote-lircd_VOL.conf or whatever it will never get overwritten. You can now choose the modified conf file in MyOSMC

#22

I’m going to add support volume up and down during playback using arrow keys

1 Like
#23

Hi,

If it is on FF/REW instead, then it can be global, not just in the fullscreen playback screen. I never use FF/REW - I wonder if others do…

:slight_smile:

#24

Hi,

is there the possibility that the Kodi17 do not longer look on the /.kodi/userdata/keymaps ?

Regards

#25

No, this should still work

#26

it works in the current Kodi 17.0 Beta 5, on my install.

I currently have my system mapped so that on the OSMC Remote:
a) Full screen video: up/down=volume up/down
b) Full screen audio/visualization: up/down=volume up/down and left/right=prev/next song

#27

On my VERO 2

I created the file ~/.kodi/userdata/keymaps/customkeymap.xml
with the following contents:

<keymap>
 <visualisation>
  <keyboard>
   <key id="166">volumeup</key>
   <key id="167">volumedown</key>
   <key id="168">skipnext</key>
   <key id="169">skipprevious</key>
  </keyboard>
 </visualisation>
 <fullscreenvideo>
  <keyboard>
   <key id="166">volumeup</key>
   <key id="167">volumedown</key>
  </keyboard>
 </fullscreenvideo>

EDIT:
When using this configuration on my Vero 2, it works well IMO.
The only problem so far, is that many skins do not automatically use the Visualization screen when playing music. This could be a good option for the OSMC skin setttings.

Muting would be another nice option. A “long press” would probably be the best way to handle it.

Note: That config file may not work with a Vero 1 remote. I have no way to test that.

#28

Sounds like a great solution Spinner! But how can I create this file?

#29

There’s some info on editing files at the Wiki. If you still have problems let us know what you tried

#30

I’ve solved it with the keymap editor add-on. http://kodi.wiki/view/Add-on:Keymap_Editor

This way I didn’t have to mess up my brand new Vero 2 device with creating files myself.

Thanks a lot!

#31

I have a follow up question there. So I modified the up/down arrows in ~/.kodi/userdata/keymaps/remote.xml for VolumeUp and VolumeDown (on my Rpi3). It works like a charm, no problems here. However, I would like to have the rewind/fast forward buttons have this function globally. So I set the “forward” and “reverse” in the “global” section to VolumeUp and VolumeDown and I can control the volume anywhere. However, unlike the arrow buttons, the rw/ff buttons do not repeat automatically, i.e. I have to press 50 times to get the volume from 50% to 100%. How can I change this? @sam_nazarko this isn’t a hardware feature of the OSMC remote, is it?

Cheers,
Johannes