RealVNC remote desktop OSMC home display - I can't do anything

I’m not sure what has happened over the past few months -

At one time, I had RealVNC working so when I logged in, I got the active OSMC desktop that mirrored exactly what I saw on the TV. Now, I believe (but am not sure) that after the January update, now all I can see is the purple OSMC splash screen. I also have a mouse cursor, although it is a very small white “x”. I have clicked everywhere, but I’ve yet to find a link on the screen that will get me anywhere.

Using a Raspberry 2, running the current April update. I am also running a bluetooth remote keyboard and all works correctly with it when viewing onscreen of the TV. The problem I have is related to when logging in via RealVNC and trying to move through the screens of the Raspberry as I would if using the bluetooth keyboard.

Thanks in advance all!

As the VNC server is not part of OSMC do I assume you have followed this guide?

Maybe you best continue your troubleshooting in that thread.

So on the TV you see the osmc gui but when you remote control via VNC you see the osmc logo and a white x only ?

If that’s the case:

  1. Log in with putty console to the pi and type:sudo modprobe evdev
    Then log in with VNC again. Do you see anything different ?

  2. Are you using a Mac ? PC ? What is the address you are trying to connect ? Do you add a :0 or :1 or something at the end of the ip address ?

  3. Log in with putty and try restarting the vnc server before you connect again:
    systemctl restart dispmanx_vncserver
    Does that fix the problem ?

Thanks for your inputs fzinken and Sandbird!

fzinken - I did use that guide to install and everything was working perfectly, I think up until an OSMC update either in January or later this year. Note, this was on a total new install from mid December. I’m a noob at this, but that also means I may have screwed something up.

To Sandbird and all - I will try Sandbirds suggestions and review the info again from fzinken’s pointer when I get back from a trip out of the country in a couple of weeks. FWIW - I am using a Windows machine to mirror the Raspberry. I am able to see the Raspberry via HDMI on the TV without issue.
My purpose in having the mirroring capability is so I can play with the Raspberry while watching regular TV. I open both a VNC session so I can see results of my actions while Putty allows me to manipulate at the system level when needed.


I’ve returned from out of the country and have had a chance to play around with this again.

To fill in some blanks -

I am using a Windows 10 machine running VNC Viewer to access the Raspberry. My login ip to the pi is without any additional modifiers. I can ssh, ftp, and VNC login to the Raspberry using the same address.

What I see on my laptop is the OSMC desktop? (shades of blue green and purple triangles) screen with “O S M C” in the middle.

I did try Sandbird’s sudo modprobe evdev suggestion but no change. I then tried his 3rd suggestion adn I think this is where the error is. I get a return statement "Failed to restart dispman_vncserver.service: . . . . . ", but being a novice, I don’t know where to look next. Through ftp I can see the file is in my /home/osmc/dispmanx_vnc-master directory on the Pi.

I’m suspect there may be an issue with the “x” in “dispmanx”, either at the file or directory level.

hmm ok forget the service for a moment (that part tha autostarts vnc server). Do the manual starting for now.

I assume you have left the vnc folder inside the osmc folder.
Go to it with : cd /home/osmc/dispmanx_vncserver-master
(If its not called that…then do cd /home/osmc then type ls to see what folders are in there…Then do the appropriate cd to get inside…ex: cd dispmanx_vncserver

You should have an executable inside there called: dispmanx_vncserver (again with ls you can see)

Then do : chmod +x dispmanx_vncserver
And finally : ./dispmanx_vncserver

You should see some stuff running, like frames going up/down all the time…Try to connect after that from your pc…do you see the osmc enviroment ?

Do ctrl+C on the console to stop the vncserver after and report back.

I am having the same problem. I tried all of the above too.They did not help.