Reboot freezes at splash screen 50% of the time

Hi everyone, bit of a weird one this. Been using Raspbmc for over a year now without many issues. Finally decided to take the plunge and upgrade to OSMC, however I’m getting a weird reboot bug. I use a Raspberry Pi 1, version B, with a dedicated fully authorised power supply bought with the Pi from RS Components. I’ve noticed that when I reboot, whether that be from the UI or via sudo reboot, 50% of the time, I reboot back into the OSMC splash screen which then locks up and goes no further. I learned the hard way that pulling the plug at this point will trash the card (had to buy a new expensive Samsung EVO class 10), and the only way out is to wait the 10 to 15 minutes before finally getting a black screen, at which point it seems to become safe to pull the power cord out.

Any one have any ideas? Like I said this never happened with Raspbmc, and it happens about 50% of the time with OSMC. Sometimes a reboot works perfectly, but whenever I see that OSMC flash screen, I’m always a wee bit on edge as to whether it will actually finish booting or not.

Uploading your logs would be a good start.

A fresh install of OSMC doesn’t randomly hang during boot so it can only be one of two things - either a hardware issue, or some software that has been installed or configuration changes that have been made.

What do you have your overclock set to, have you tried dropping it to a lower speed or even right back to Normal ?

Have you installed any additional software using APT ?

If you have access to a voltmeter and your Pi 1 is a model B with TP1 and TP2 can you try measuring the voltage between the test points and make sure it is above 4.75v at the time it is hanging ?

When it seems to hang, are you able to log in via ssh ? If so can you try capturing the output of dmesg and the system journal - you can do so like this:

dmesg >/boot/dmesg.log
sudo journalctl >/boot/journal.log

This will copy them to the FAT32 partition so you can upload them to

By the way pulling the power out will NOT damage your SD card, I’ve done it dozens of times on my test devices without issues, and there is no reason why it would cause hardware damage to the SD card. It is quite possible it will corrupt the contents though. (although I’ve only had this happen to me once)

Your original card probably just needs fully wiping with SD Formatter V4.0 to get it working again.

One final thought - is your Pi 1 an original B with the full size SD card slot ? If so, those are very prone to the contacts losing their tension over time with the end result that you get a poor/intermittent connection to the SD card which causes random freezes on boot and random disk errors.

I had this happen to my original Pi 1 B - it was particularly bad with any micro SD card in a micro SD adaptor and it got to the point where it wouldn’t boot reliably (or at all) without a small piece of writing paper inserted between the SD card and the slot (on the non-contact side) to pad out the thickness a bit and put more tension on the contacts.

Well the first time it happened, all I had done was installed OSMC and allowed it to set itself up, accepted the EULA, then went to My OSMC, then Pi Config, then added my MPEG and VC1 licence keys. Then I went to reboot…and that’s when it booted into the splash screen and hung for around 15 minutes until blacking out completely.

It’s happened at other times too, I recently installed Deluge and Deluge-web and performed a reboot after configuration. But it’s so random, sometimes rebooting isn’t a problem and other times it is. I’m on the default Normal overclock setting in OSMC.

I’ve tried SSH-ing into it when it hangs but I get Connection Refused in Putty. Also those commands to save my logs don’t work, I get “Permission denied” with both of them, I don’t know why…

I do indeed have an original Pi 1 B. Regarding corruption of my original card, this actually happened with Raspbmc. It was on and was idling, the Dim screensaver was on which has never been a problem before, when all of a sudden the screen went completely black. I pulled the power cord and then plugged it back in to reboot…and nothing happened. I formatted my card using SD Formatter and tried to put both OSMC RC1 on it or even the last Raspbmc image file, but I could never get the card to ever boot again. All I got was the rainbow screen, or an error message about Kernel Panics in block 192 or something. I cut that card up and chucked it in the bin…

Incidentally I have my Pi connected to an Onkyo NRTX414 which is then connected to a Sony Bravia W8. I don’t know whether going through an AVR might ever cause the splash screen to hang?

Ha guess what? I just disabled Debugging (after having enabled it to try and get more verbose logs). Went to reboot and…yep, it’s hung at splash as I’m typing this right now…

Okay so once I had waited for the splash-hang to black out, unplugged and replugged my Pi, booted then temporarily raised my privileges with sudo -i. Have captured journal and then dmesg, available at

Just rebooted again and I’m stuck at the splash screen. It’s getting like 80% of the time now it hangs. I never had this trouble with Raspbmc. Perhaps it’s better to choose Shutdown and just not use Reboot any more.

Edit. Is it anything to do with my external hard drive attached via USB hub? It’s one drive but has a 130 gig FAT32 partition and a 100 gig ext4 partition (used for Deluge). Perhaps Reboot bugs out trying to mount a dual partitioned USB drive, but a full Shutdown and Startup gives OSMC more time to work out what is going on? Perhaps I’m clutching at straws here trying to work out what the issue is.

Try unplugging it and rebooting a few times and see if it still hangs…

Was this with or without your external drive connected ? If this happened without the external drive connected then it’s almost certainly a hardware issue I’m afraid. A fresh install is not going to randomly freeze on boot on your Pi but work for thousands of other people.

Did you try some paper to pad the thickness of the SD card as I suggested ?

Sorry for the late reply. It happened with the external drive connected, via a powered hub. Haven’t tried the cardboard thing because this never happened with Raspbmc, it’s only started happening with OSMC. Which leads me to believe something fundamental has changed with the new OS and the way it boots.

Never mind, I’ll just no longer ever use Reboot then…It only ever happens on Reboot, NOT when I start up from fresh, or when I do a full Shutdown, unplug and then plug the lead back in again. Only Reboot. So weird…

Reviving an old thread here, but I have had this too in the past, and each time pulling the plug resolved it. Today after an update I got the OSMC splash screen and nothing else but this time pulling the plug didn’t help. SSH wouldn’t connect and the IP wasn’t pingable. Eventually I suspected the power supply so in desperation I swopped it for another which was actually underpowered. The Pi booted up again with the rainbow square in the top corner, and this time I got to the main menu, which then turned into the sad smiley. So I swopped the original adapter back (a recommended RS Pi adapter) and it booted fine. No damage has been done to the OS or SD Card (it’s a PI2) so I shall be watching future updates carefully.