Recently started random audio drop outs

Hey guys,

Recently, within the last week or two, so possibly to do with the July update I’ve been having issues where the audio will randomly drop out. I’ve not been able to find any pattern to it. It mainly happens with standard stereo but also occasionally with DTS passthrough as well. It doesn’t seem to be an issue with memory or CPU usage etc. Everything had been playing absolutely fine beforehand and nothing has changed in the setup. I have a rpi2 with latest osmc going through an Onkyo amp to a Panasonic tv. I’ve had the occasional CEC problem but never had any issues playing any files.

I tried different settings and it seems to be something to do with either the refresh rate or the fps (although I know they are linked!) The main files that seem to have the drop outs are 60fps, but ones which are 29/30fps also have them but not quite as often. If I turn off the adjust display refresh rate then it seems to solve the problem. Previously I had it set to on start/stop and it worked fine. Here is the log when I’m playing a 60fps with adjust display rate to display switched on:

Any suggestions? Thanks!

Have you enabled omxplayer in video/acceleration settings recently?
It is disabled by default (only recommended on Pi0/Pi1). Try disabling it again.

Hi, I’ve always had both the acceleration options selected and never had an issue before? I thought I read that omxplayer is faster? I’ll try turning it off and see. Thanks for the reply.

omxplayer is rather more basic. It supports fewer features and is kept around for Pi0/Pi1 users who benefit from the lower CPU. (Pi2/Pi3 are so much more powerful in comparison that the CPU difference is negligible).

One thing omxplayer does by default when adjust display refresh rate to match video is enabled is to make small adjustments to the HDMI clock to mainstain A/V sync.

The changes are below 0.1% which should be fine according to HDMI spec, but onkyo is known for dropping audio when this feature is enabled.

So, assuming disabling omxplayer has avoided the issue, then you can also test with omxplayer enabled and “adjust display refresh rate to match video” disabled which again should avoid the issue.

You can also limit the amount of clock change with, say, “hdmi_clock_change_limit=50” in config.txt which will likely avoid the issue if you choose a sufficiently small number.

But really you should just stick with MMAL and leave omxplayer disabled if you aren’t using a Pi0/Pi1.

Sorry for the delay but thank you for the really indepth answer. Your idea was spot on and since disabling the omxplayer I’ve had no further issues.

I’m just still surprised that the issue appeared out of no where!