Red flashing cross on V4k+

I feel like I know the answer but I will try anyway.

I discovered my Vero 4k+ this morning with flashing red from the + indicator light. The box typically does not get turned off so was running near constantly at least since the new year, except reboots for updates (most recent I think in the last week). When I left it last night it was working without issue that I noticed but as mentioned this morning it’s non responsive

It seems dead, in so much that plugging power into it, the only thing it does is immediately start with the red flashing. Nothing gets output to the display over HDMI so it seems quite hard to troubleshoot.

I have tried different HDMI inputs in case that was a problem, as well as moving power to different sockets, e.g. connected to a UPS, connected to a power strip, connected directly to wall.

Are there any things I could try to troubleshoot further?

Does the light flicker or is it on solid?

Sorry sam, I omitted that. It blinks on and off, not solid

That might be good and mean just the power supply is affected. Have you tried powering the device via USB?

Have you tried powering the device via USB?

Stupid question incoming, but how? I only have USB-A inputs.

Connect it to PC or powered hub and to one of the ports on the device.

Hmm, so the v4k+ can be powered by the usb-a ports on it? I did not think that was possible only USB-A from a power source to usb micro-b or usb-c, neither of which the vero 4k+ has that I can see. Just two USB-A ports

Yes you can power the device via USB-A.

Well I’ll be. No real change though

  • USB wall socket (5.1v 2.1A) USB-A cable to wall → USB-C to dongle converting to USB-A plugged into vero: no signs of life

  • GAN charger (5v 3a) usb-C to charger → USB-C to dongle converting to USB-A plugged into vero: light flashes red like with the plug that came with the vero

  • The same GAN Charger with a usb-c to usb-a cable (no adapters): no signs of life

  • A wall charger from Rapberry Pi (5.1v 3a) with usb-c connector. usb-c to usba-a adapter connect between it and the vero: no signs of life

  • I also did try a plug with swappable tips whch was 5v / 1.5a but that also showed no signs of life

You can’t use an adapter, both sides need to be USB-A

So the usb-c to usb-a without adapter is no good too?

No - you need a USB-A cable

1 Like

Thanks. I’ll see what I can find locally. Should I be aiming for 5v/2a on the plug side or anything else compatible

Anything over one ampere should be fine. Don’t try to plug anything that draws any significant current into the other USB socket as backfeeding it from the USB socket limits how much power it can draw as it is only rated for 500 mA.

1 Like

A bit of progress made. male USB-A to male USB-A sourced and plugging in to wall I can now get a solid red light on the box as long is it is plugged in.

Unfortunately it does not output anything on HDMI nor can I ping/ssh to it as I was able to reviously. dhcp server does not sees any requests coming from it.