Red led all of a sudden

My Vero 4K no longer turns on, I’ve tried removing the power supply for longer times. The device itself is cool to the touch. Every time I reinsert the psu, the LED flickers a bit in red and then stays red.

I tried powering via the white USB port and an Anker powered USB hub but the device doesn’t react at all, might be related to not having a proper usb a to usb a cable and using an male to female usb a adapter though.

Any help would be greatly appreciated. For the same reason I can’t connect it directly to a pc. I have a whole box of usb cables it seems but none of them are usb a to usb a and with lockdown all shops are closed atm.

From the symptoms it is very likely that your power supply is faulty/the voltage is too low, meanwhile.

118 / 5000

Some time ago @sam_nazarko provided some links on how to order them in the osmc shop, see his post

Other way would be to get one somewhere else, specification: DC 5V, min. 2A, center positive, coaxial power connector male with OD 5.5mm and ID 2.1mm

1 Like

Cheers! I was hoping it would be something simple like that.

I’ve ordered an equivalent psu via and will give it a try. If that doesn’t work I’ll order a psu from the shop and return the other one. It’s amazing how I managed to not have an equivalent psu lying around after all these years.

Just for clarification, the psu in the shop lists it for “USA” which probably means it’s not EU compatible. But if it happens I’ll have another look and ask to make sure I pick the right one. Who knows how long it’ll take moving forward to get something from the UK to Germany :confused:

Thank you for the reply and the helpful advice. I’ll update this thread once I’ve received the PSU from Amazon and tried it out.

New PSU arrived and it seems to start again, no picture alas. I’ve tried booting it multiple times, the light is blue for a bit then turns off as if it’s booting normally. But there is no signal. The device does not show up in my network either.

If it is a Vero4k, you should see on cold boot (inserting power connector from power supply): Very short a red light followed by constant blue light. I’m not sure how to interprete the symptom that the blue LED turns off after short time.

Thank you! Oddly enough, now it’s red for a brief time and then remains off again. But at least it turns on blue for a short moment. @sam_nazarko can you assist me?

Now the vero4k seems to be up again? I haven’t done a thing just turned it off and on earlier several times and waited in between for about 10 minutes. The original remote doesn’t seem to connect though, can someone point me to the proper way to connect the original remote?

Nope, had to disable and enable BT. It seems things are working again. :slight_smile: cheers!