Red light of death

Trying to fix a friends Vero4k with red light of death.

I’ve tried my working power supply, just red light.
Tried downloading latest build, used the installer to copy it across to a USB stick.
Power on with USB stick in, just red light.
Tried the toothpick method, everything plugged in inc. USB stick, press toothpick in for 10 seconds, 30 seconds, 1 minute, no change stays on red light.
No external drives in use.

Is it dead or anything else I can try?


Can you show a screenshot of the contents of the SD / USB?

When did it last work and what was he doing with it?


Screenshot of USB contents

I asked and it last worked a few months ago, I think he asked on here but gave up getting it working so I had a go as I’m a little bit more tech savvy and also have a working unit to try the PSU with.

A solid red light means the device isn’t booting. Is it possible at some point he used the wrong power supply?


I thought this and asked but doesn’t have any other Power supplies that’ll fit let alone be the wrong voltage etc. hence asking me to try my one as numerous forum posts suggested power as the problem.

You could try attaching a USB-A cable and seeing if it’s recognised on a PC.

Hi Sam,

Can you explain this method further please as to what result I’m trying to achieve?

I plugged it into my PC using either the white or black USB port on the Vero, the red light comes on, my PC doesn’t find any drives if I go into Disk management on the PC.

Am I supposed to power it from the PSU as well, obviously not keen on creating a short and blowing my PC up.

You don’t need to power it with the barrel connector as well. The USB port should provide enough downstream power.

You should see if the device is detected in Device Manager at all. If it is, it’s possible the system is corrupted and we can restore the software. Otherwise, there’s something else wrong with it.


If I plug it in with Device manager open it does nothing as in doesn’t change the view, if I scan for hardware changes again it makes no change to the view.

I’m assuming it would appear under “Universal Serial Bus devices” or perhaps somewhere else?

If it’s not showing up at all, then the hardware has likely failed. I’m not sure what you can do with it without sending it back to us to look at.

Ok I’m assuming he needs to raise a support case and there’s a cost associated?

He can send an email to with his order details so we can check warranty.

Long since out of the years warranty so not much point now.

We can always take a look at the device, provided your friend accepts that we might not be able to repair it.I’m guessing it’s an older Vero 4K and not a 4K+ model.