Red light on Vero 4K+ if booted with HDMI connected

About a month ago (after ignoring the OSMC update prompt for many weeks) I decided to let my Vero 4K+ update to 2021.08-1.

Following the update it would not boot with the HDMI cable connected, instead showing the Red Plus Light of Doom (or RPLoD) with no response to ping or SSH.

Either pulling the HDMI cable or power-cycling with the HDMI disconnected allowed the Vero to boot normally, and would respond to ping/SSH within 20 seconds.

If I then re-inserted the HDMI cable I would see the GUI, but the OSMC menus had no text. After a bit of searching on this here forum I found that restarting the mediacenter service via SSH would make the GUI display normally, which it would continue to do until the next reboot, at which point I would be back at the RPLoD.

I lived with this for a short while, then decided to start afresh by Reinstalling OSMC.

Unfortunately I’m faced with the same issue after doing so. And after reading Vero4k+ stopped booting (power issue?) and Vero 4k does not output HDMI signal I feel like the issue is caused by the 2021.08-1 update (as reinstalling obviously installs the latest build too).

I’m going to try rolling back to 2020.11-1 next to confirm this and will update here once complete. Here are some debug logs from the latest reboot / red-light / pull-HDMI cycle:

Can you please boot the device and run the following command:

fw_printenv | paste-log

and send the output



Hey Sam. Sure thing, caught me just in time before I started the reinstall to 2020.11-1


We are chasing a similar issue – but it doesn’t appear to be the same cause and the version you have installed should not be affected. You haven’t ‘forced’ an HDMI mode, which is what would cause the issue reported in another thread.

Instead of reinstalling (doesn’t matter if you have), I’d be interested in knowing if your issue persists on the staging repository.

  1. Login via the command line
  2. Run the following command to add the staging repository:
    echo 'deb buster-devel main' | sudo tee /etc/apt/sources.list.d/osmc-devel.list
  3. Run the following commands to update: sudo apt-get update && sudo apt-get dist-upgrade && reboot
  4. Your system should have have received the update.

Please see if the issue is resolved.


I can see your problem.

If you run sudo fw_setenv hdmimode 1080p60hz this should solve it.

I’m not sure why your firmware environment is corrupted like that, but this should solve the issue.


1 Like

Aha! It now boots/reboots with the HDMI connected. Thank you!

NB: I didn’t run the staging repo commands in your previous post, only set the hdmimode environment variable.

I’m not sure why that variable wasn’t set, but I’ll fix the underlying cause of the crash when it isn’t for the next update.



1 Like

Top drawer, cheers Sam. Now I just need to figure out why I’m getting websocket connection errors in the Chorus2 web interface post-rebuild, but I guess that should go under its own thread once I’ve had a search around. Thanks again!

I’ve taken a belts and braces approach to solving this problem, and the solutions should be in the next update.

Firstly, I’ve ensured that re-installing OSMC in the future will configure the UBoot environment to match the defaults provided by the bootloader that is packaged:

So in your case onwards, if you were missing that hdmimode parameter, it would be reinstated automatically after reinstalling, which would solve your issue.

I’ve also got a patch to solve the original crash which occurred when that parameter wasn’t set. It’s been verified by a user but I’ll wait for a bit more testing before pushing it to the development repository.

Thanks for the report



1 Like