Refresh button missing from info screen

Hi, my vero4k mispicked the info for a movie (there were 2 Invasion movies in 2020) but I can’t find a way to pick the right one. I even added an .nfo file with the IMDb address, but it seems to ignore that. I remember there was a Refresh button earlier, but I can’t find it now.
The actual movie is found in Extended info but when I select that one, nothing happens.

Which skin are you using?

Can you show a photo?



It is probably just off screen and you need to use the direction buttons a bit more. In Estuary it is the last option so when you go into the info screen you can navigate left once to get to the option. As for the parsing nfo file the url has to match what your scraper is. So if your scraper is set to TheMoviedb then you need to provide a link to the listing on their site. If your file (or folder depending on scraping settings) doesn’t include a release year then adding that may also fix the issue as well. Do note that sometimes there is a disparity between the year an acquired movie is named as having and what year is found on movie information sites (ie one might use a premiere date and another general theatre release which may be a year later) and the file would need to match what is listed on the site used for the scraping source.

1 Like

That’s a little insulting, but yeah, sometimes I wish I was that stupid.

I have the release year in every folder’s name and every file’s name.
With regards to the nfo, I was following the advice of the OSMC official support who told me to use imdb links. I’ll try the movidb one (since there is no imdb scraper).

I’m using the Estuary skin. There “refresh” button vanished. I tried the official OSMC skin this morning, it has a refresh button, but it’s greyed out, so I switched back to Estuary.

If I click on Extended Info, I get a variety of movies called Invasion, including the correct one. If I select that one, it opens the extended info, but if I close that, it goes back to the wrong movie info.

I also noticed that the cast is unavailable everywhere now.

This sounds like maybe your scraper before the update was set to the old TMDB scraper and that has now gone so it would make it so you no longer have a scraping source set at all for your movie libraries. It should just be a matter of going to videos>files> then highlight your movie source, then context menu>set content> and then you should have the new option already installed that you can select which is the TMDB Python scraper.

Not my intent. There was no way for me to tell from your post what your knowledge level of Kodi was. Even then sometimes people just don’t know certain things. In this case it is not visible in Estuary when you first pull up that info screen and I would expect many people to not realize that is is actually a side scrolling list.

I think the Universal scraper may use IMDB as a source. I’m not sure as I’ve never messed with it. I am quite certain that for parsing nfo’s when your scraper is TMDB (movies or series) the url must be pointing to TMDB. One more thing I didn’t think to mention is also the language set in the scraper can factor in when on a movies listing on TMDB has a different language specific title. You can sometimes use this to your advantage by looking on IMDB for “alternate titles” where you can find that Invasion (2020) should also match to “Attraction 2” and “Attraction 2 Invasion” if renaming like that is preferable to having a parsing nfo file.

1 Like

We can all be idiots, be tired, or make mistakes. And we can all look for the easiest / most obvious solution as support staff.

Many a time I’ve tried to chase down an issue, like nothing on display, to find out the HDMI cable I was intending to test with is simply not connected.

1 Like

I’ll try your advice about the scraper, because I added a movie yesterday and although I scanned the library, it never showed up. So I think it could be that.
I’ll check back when I have results. Thanks for the help so far. :slight_smile:

So I had to disable the universal scraper and everything started to work.

Disable the universal scraper? Just setting the scraper to TMDB Python and refreshing the source by itself didn’t do the trick?

It was already set to TMDB Python.