Refresh rate sometimes not switching correctly

#1

I’ve had a few instances lately where my Vero has switched to 59.94Hz instead of 23.976. Rebooting seems to fix it, at least for a while.

I’ve attempted to capture logs, but because I can’t reboot without making the problem go away, I’m not sure how useful they’ll be.

https://paste.osmc.tv/unukerosus

#2

Debug logs might help.

#3

Debug logging was turned on when I posted the link in my previous post.

#4

Sorry, didn’t scroll down far enough :roll_eyes:

#5

Yeah, sorry, I realise the logs are probably very long - as I said, I can’t reboot before logging the issue happening, because rebooting actually fixes it for a while.

Anyway, you’ve got what you need…?

#6

Can you try enabling HPD Lock and rebooting?

Sam

#7

No, 'cos I don’t know how to do that. :rofl:

But if you tell me how to, sure.

I’ll presumably have to wait till the issue occurs again(?) which might take a while…

#8

It’s under Settings -> Display. Reboot after enabling

Sam

#9

Kodi is just not matching 4k23.9x in the metadata to the appropriate resolution. I will try to reproduce this. Could be some unsexpected rounding going on.

@angry.sardine did you have look if others are getting this on the Kodi forum? It doesn’t look to be OSMC-specific. Of course, most users won’t notice unless they get stuttering or lip-sync issues.

#10

I did not, but I shall do so when I can.

#11

I’ll give that a try. What does it do, exactly?

#12

I think it just stops Vero reacting to HDMI hotplug events. If your log has some times where it works then there’s hotplug event, then it doesn’t work that might provide some clues. And hotplug events don’t necessarily mean unplug/plug.

#13

That’s right. What I suspect might be happening is that this issue is only presenting after a power cycle on @angry.sardine’s AVR or TV. Hence the issue only occurring the next day.

Sam