Refreshrate question/problem

Hi again,

I just received a new TV, a Sony XF9005.
Setup is as followed:

-> Vero 4K with an “old” 2TB USB 2.0 external drive goes via HDMI into my AVR the
-> Denon X1300w that puts the picture to my Sony TV

I had a 50 HZ TV before. In the Kodi settings i always had chosen “adjust refreshrate at start/stop”. With my new TV that provides 100/120 HZ, this option leads to a strange phenomenon: When starting a video (no matter if 1080p or 2160p) the TV doesnt recognize an input anymore. It goes black and the TV warns me that there is no input detected.
Turning the “adjust refreshrate” off let me playback videos fine, but every few seconds (frames?) I recognize a small stuttering (judder?). This was the case with my old TV but the refreshrate option fixed that for me completely.

So I wonder what the reason is, that my new TV (with a wider refreshrate range) doesnt work with that option on.
Some testing I did:
Watched a 1080p bluray via the PS4: no stuttering visible
Tested two other HDMI cables: no change
played around with “resolution” and “Framerate” settings (set to 2160p and 60 atm)

Im prestty sure im overlooking something here, so any help would be appreciated.

Try connecting the Vero directly to the TV to rule out the AVR. (Reboot after doing that). Then we can go from there.

1 Like

Keep the GUI at 1080p and enable Adjust Refresh Rate.

Holy smoke that works!
So the avr is doing stuff. Something with the passthrough? Options are very limited there, so Im not sure what to change.

Well, before blaming the AVR, try different cables to be sure.

In the AVR, look for options that control the HDMI port versions.


Not much to choose except passthrough (source) and arc. Will test different cables from the vero to the avr now.

Edit: and it was just that: The HDMI cable between the vero and the avr. Problem solved.
Its amazing: Even after decades of experience with all kind of technical stuff, I still sometimes fail to make the most basic diagnosis…

Thanks a lot bmilham!

Sometimes it’s the simple things :wink: