Regional settings


I upgraded OSMC to last version and since then every reboot resets my regional settings.
“Set language from CEC” is disabled.

I selected French language, I enabled CEC (my TV is French language).
Reboot -> language is “English” and CEC is disabled.

I disabled all language in settings except French.
Reboot -> English and all language are enabled

As long as I don’t reboot my RPi3, OSMC don’t change my settings.

Any idea?


It might be related to this Vero 4K, sad face after changing language to swedish - #16 by sam_nazarko.


I’d appreciate it if you could test this and provide feedback before we release this as an update to other users. To test this update:

  1. Login via the command line
  2. Edit the file /etc/apt/sources.list
  3. Add the following line: deb stretch-devel main
  4. Run the following commands to update: sudo apt-get update && sudo apt-get dist-upgrade && reboot
  5. Your system should have have received the update.

Please see if the issue is resolved.

I also recommend you edit /etc/apt/sources.list again and remove the line that you added after updating. This will return you to the normal update channel.

1 Like

I will test this update on sunday.

Problem solved for me!


This update solved my regional settings error but not completely.

First thing first, before trying this update I reboot my RPi.
Setting language is back to English, ok. I keep this config.
So I quit, push ESC on keyboard and I’m in console mode.
I login osmc/osmc and console mode quit automaticaly and get back to Confluence skin with… French language! Damned…

Then: console mode, nano edit, update, upgrade, reboot.
regional setting are still in French.
2nd reboot, regional settings are still French.
Ok it works.

Then, I disabled a few languages in Regional Settings, reboot -> these few language are back to enabled.

I installed OSMC Stretch on RPi2 and had the same language problem.
I installed “update” but didn’t solve it.
Part of the skin was in French and part in English.

What’s skin you use ? Are you sure it’s not a particulary skin issue ?

My installation: RPi3 - 2017.12-1. Aeon-Nox Silvo skin. Translation Spanish.

Same problem, every reboot part of the menus in Spanish-English.

I have applied the procedure and problem solved.

Thanks Sam.

For skin I use Confluence.

Confluence it’a a external skin maked installable about after kodi 16.x it’s been released. It’s old skin and it’s no more in developing and possibly contain not all complete translation.

Problably a skin issue not related to osmc of kodi himself.