Remote battery only lasts 2 days

I have a 4k for about 4-5 years now, still works fine, except the remote keeps coming up “low power” warning after 1-2 days. tried about 6-7 types of battery, even duracell and same thing happens. Any ideas, and btw no stuck keys on remote, cheers in advance

The remote that came out that long ago didn’t have the mechanism to trigger that warning so I find this a bit confusing. Is this a replacement remote or maybe you have something else connected that may be sending a “F2” key? If the remote is still working but it is just the message you can disable it with a keymap. If you visit the following guide there is a keymap at the bottom for doing just this…


Do you have another keyboard attached?
Are you using the original remote supplied with the device?


No, there is no keyboard attached, the battery actually dies after a day or two and the remote wont work.
The box sits under the tv, and is cabled to the router, thats it !
It has worked fine for years, now it runs batteries down like hell. The remote is in as new condition, not dog chewed, or dropped.

Is this as simple as just a faulty remote ?

The remote wouldn’t go faulty on its own. There could be two issues:

  1. You or a neighbour has a new device that’s causing interference and the remote is constantly hunting for a free frequency and this is causing battery drain. You could hold Home and OK to re-pair the remote.
  2. There could be a short circuit. This sometimes happens if the battery contacts are damaged. This can happen if the customer uses a sharp instrument like a knife to prise the battery out when replacing it after it has run out of charge.