Remote control keeps turning off after some time


I have a problem regarding OSMC + Yatse (remote control) environment. Firstly I thought it will be a problem of Yatse, here is the description of bug report I filed on Yatse pages:


I use Kodi (well, actually OSMC which is just a Kodi “wrapper”) on Raspberry Pi 3 and your great remote control, Yatse, on Android device.
When eveyrthing works, it works great. However, for past months I have been experiencing remote control malfunctioning irregularly once in a day or two.
Basically it keeps turning off (showing me that the device is offline and not responding to controls) after some up-time.
The most extreme scenario that happened to me and demonstrates the case is that I played an episode of a series with Yatse, it played for 20 minutes, I wanted to play next but the remote was not working anymore.
The more common case is simply watching a movie and coming to Kodi the next day with not anymore functioning Yatse.

I can’t figure out what is making the remote suddenly not working.
What I know is:

  • there is a workaround for remote not stopping working - if I leave Kodi in any kind of plugin screen (e.g. YouTube search screen) - it becomes immune to stopping working
  • I have feeling that most of the “stops working” times are around the mid-day, however it is merely a feeling
  • when the Yatse remote problem happens and I connect external USB keyboard, I can control Kodi with it without any problem, Yatse however remains non-functioning - therefore it seems that the problem is not in global controls mechanism, but specifically in the way Yatse communicates with Kodi
  • when the problem happens, I can access Kodi web interface from one of my local computers and control Kodi from it as well - therefore the network communication seems to be OK as well
  • the only thing that solves it is plugging off and on RPi or simply connecting to the Pi by SSH and restarting mediacenter service - after restart, Yatse works again

I hope I haven’t forgot anything important.
Also attaching Yatse and Kodi logs.
Please, can you help me with the issue?

Thank you,

And after a few minutes, there was following reply from Yatse developer:

The fact that rebooting OMSC and not touching Yatse gives a big hint at where the problem relies :slight_smile:

[662] HTTP FAILED: Failed to connect to /

Your OSMC stop responding for an unknown reason :frowning: I guess some thread gets locked on Kodi due to a bug on Kodi or OSMC

And if the remote buttons does not work too then issue is maybe network related on your phone as it use another protocol.

So now, I’d kindly want to ask OSMC community (and probably creators) if you can help me with the issue. :slight_smile:

Here are the logs:

UPDATE 19.11.: support thread on Kodi website has been opened.

Thank you,

Hello ActionA,

I’m sorry, I have absolutely not thought about that. Edited.


1 Like

I would say that as you can restore service simply by restarting Kodi that this is most probably a Kodi issue not an OSMC one.

Just to clear up the understanding; OSMC is the operating system (not a wrapper for kodi). Kodi is a piece of software that runs on top of that operating system. Just like on a PC Kodi may run on top of Windows.

If restarting Kodi resolves the problem then it is unlikely to be the underlying operating system.

Thank you for your response.

So to be sure that I understand it correctly:

  • Kodi that runs on OSMC is unmodified by OSMC?
  • if I run command sudo systemctl restart mediacenter am I restarting Kodi service and having nothing to do with OSMC?


Some changes are made for it to run smoothly on OSMC.

I think Kodi 17.5 had some problems and these were resolved in 17.6 You could try them.

  1. Login via the command line
  2. Edit the file /etc/apt/sources.list
  3. Add the following line: deb jessie-devel main
  4. Run the following commands to update: sudo apt-get update && sudo apt-get dist-upgrade && reboot
  5. Your system should have have received the update.

Please see if the issue is resolved.

I also recommend you edit /etc/apt/sources.list again and remove the line that you added after updating. This will return you to the normal update channel.

Sam, thank you for the tip, I updated the system and will let you know if it helped.

OK, update to Kodi 17.6 didn’t help. I have waited and tried some more things since and now my problem is fixed. It looks like the January OSMC update has fixed it. My uptime is now at about 9 days which is probably the longest it has ever been since experiencing the issue. :slight_smile:

Thank you very much for your help!