Remote control no working.... again


Is not the first time that I seek some help regarding that issue. But even not solving the problem, I discarded and keep using the system because is just awesome.
So, I have a LG TV model 49UJ7500-SA.
Recently I upgrade to a Raspberry 4 and did a fresh install with no backup restoration at all.
And the remote control worked flawlessly. Suddenly, not anymore. It’s been several months already, but yesterday I realize that I’m not using som much because the lack on remote control. Yatze is a excellent tool to interact with Kodi, but not so easy as the remote control.
Usually I search the internet to get any idea of what is the problem and how to solve or even mitigate, but this issue is my Achilles’s heel.

What I already did:
1- shutdown RPI and remove from outlet. Did the same with TV. No power at all on both. Turn on the TV first and then the RPI. No avail.
2- I already use the HDMI port closer to the power connector in RPI. And I’m using port number #2 in TV
3- I know that cec-client breaks the connection between TV and RPI, so I perform the step #2 one more time.

To prevent reinstall the whole system, which I don’t really mind because I let it updating my library during the night, There is any way to reset the whole thing? Mainly for it to re-detect which remote controller I’m using…

The logs are here: (
I read somewhere that VPN Manager addon creates a lot of rubish in log, That’s why I enable just for this and if it need more time to generate the right “errors” or messages, I temporarily disable VPN Manager for that.

The test that I made during the logs, begin on line 27288 to 27297. That is how full the log is…

As always, thanks a lot guys. Any help is very appreciated.


There isn’t a whole lot that can be seen in standard logs regarding CEC. Kodi isn’t showing it registering as an input though so I’d guess that either CEC is turned off in Kodi’s settings>system>input>peripherals>, You have a HDMI cable or adapter that isn’t connecting pin 13 (and if your using a micro HDMI to HDMI adapter you really should get a proper cable that doesn’t need an adapter), CEC is disabled in your TV, or else you have something else plugged into the TV that is grounding the CEC bus so no CEC device work.

1 Like

good points.
I brought the HDMI cable when I notice that the adapter was not working correctly, basically one month after RPI4 arrived. Almost a year ago.
There is nothing under “settings>system>input>peripherals” blank space. Should it have something there?
LG uses Simplink and yes, it is ON. That was something that I did too, but forgot to list. Disabled Simplink, shutdown rpi, enable Simplink and then turn on RPI.
Could you show me what is the connect CEC on kodi logs? Out of curiosity and to know what to look for when it works…

Thanks Darwin… a lot

A standard Kodi log will only show this…

info <general>: Register - new cec device registered on cec->Linux: CEC Adapter (0000:0000)

and after that happens you will see a “CEC Adapter” entry in that peripherals settings window. Unless you had done something in the OS that touches CEC then I would first unplug any other HDMI devices from the TV if there are any, Unplug the TV and the RPi from the wall for a minute, and then plug everything back in and see where your at. This would be to isolate away from any other CEC devices pulling the bus down and also reset the CEC assignments in case for some reason the TV got a case of the stupids. If that has no effect then you can go two different directions. You can plug it into a different TV using the same HDMI cable your using now to try to determine if the cable is working, or you can just try another cable with the same TV for the same reason. All CEC communication happens on a single wire that isn’t used for anything else so it can be non-functioning without it affecting the picture or sound.

The only other thing I can think of is if you have the magic remote and programed the input it is plugged into for something it thinks should have CEC. I’m not 100% if that TV would actually stop CEC with that kind of setup but from what I remember playing with it when I first got my LG is that if you told it you had certain kinds of things plugged in then it switched over to IR control instead of CEC. I think for anything that you actually wanted to control via CEC you were best off to not have configured at all in that device connecter setup (I might have the name of that wrong, but the settings where it does the smart connected device setup stuff.)

My magic remote broke a few months ago. And OSMC worked with the “new” remote. And I don’t remember fiddle so much with the TV settings…
I’ll definitely try all your suggestions tomorrow.